Jump to content
Sign in to follow this  

250xc tranny reassembly woes

Recommended Posts

I am reassembling the transmission on my 250xc. I put it all together the way I thought it should go, but when I tested the shifting, it was all off. it was in gear in neutral, and wouldnt shift well. So I took it apart and swapped the 2 shift forks, thinking I got them confused. Now it is locked up in the only 2 gears It will shift to, so im pretty sure I had the forks right the first time.

Has anyone experienced something like this? Next I am going to double check that I didnt put a gear on backwards or something. Hoping someone will have a tip, before I split the cases for the 3rd time!!!!

Share this post


Link to post
Share on other sites

You could likely find a fish on line and poss cross the ##s

Try running it through the gears before completly bolting the train down.

Share this post


Link to post
Share on other sites

normally on the tranny will literally only go together one way. if you must you can look up the parts fiche and start counting teeth on the gears otherwise you may need to work(turn) your countershaft while working the clutch side or gear back and forth sometimes it doesnt like finding gears without finding some sort of resistance.

Edited by Ridewhenithurts

Share this post


Link to post
Share on other sites

I think I figured out the problem, unless I counted wrong the shift star has 6 spots on it. Ktm must use the same star for all their trannies? So anyway, I think, that I had put everything together with the drum rotated so it was it "6th" and ended up in no mans land. I assembled it making sure The drum would be in neutral, and everything works....kinda....everything except 5th gear. When I shift it into 5th gear, I can barely turn the shafts. Something is binding when its in 5th. Every other gear I can spin the main shaft with 2 fingers. 5th I have to put a rag on it and put some muscle into it. No rubbing sounds or anything, but definitely bad. Time to split the cases again! Im starting to get good at it. Now I know why people buy new bikes.

Share this post


Link to post
Share on other sites

Took it all apart again and found nothing wrong with it. Put it back together, And rotated the drum through all the gears and they all worked fine. Then I put the spring on the "clicker arm" and now when I shift to 4th it binds up! 5th works fine.

The roller on the clicker arm doesnt fully go into the radius on the shift star when I shift. the transmission has a slight bind to it like this. Then If I wiggle the tranny so the clicker arm sits in the star like it is supposed to in binds up just about solid. Im so freaking baffled right now.

Im sure there is something simple but I cant find it!!!!!!! Im almost certain everything is together right, and there isnt a part floating around loose.

Please somebody tell me you know exactly what is wrong!!

Share this post


Link to post
Share on other sites

GOT IT! double checked everything again, and noticed I had a shim on the wrong side of a clip. It all makes sense now. I no longer hate my KTM.

Share this post


Link to post
Share on other sites

GOT IT! double checked everything again, and noticed I had a shim on the wrong side of a clip. It all makes sense now. I no longer hate my KTM.

WOOPS! LOL :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×