Jump to content
Sign in to follow this  

keyed ignition

Recommended Posts

I have a 2008 klx450r that I bought used last year. 3rd owner. First guy had the bike shop install a baja designs blinker/kill/headlight switch along with turn signals and rear brake light. I want to add a keyed ignition/kill switch. I bought the baja part I need from TT and it seems a simple fit...but it doesn't work. I have contacted Baja and they don't know whats wrong. There was a product change recently so that might be the problem. Has anyone on here added the ignition switch to their bike?

Edited by mec

Share this post


Link to post
Share on other sites

I have a 2008 klx450r that I bought used last year. 3rd owner. First guy had the bike shop install a baja designs blinker/kill/headlight switch along with turn signals and rear brake light. I want to add a keyed ignition/kill switch. I bought the baja part I need from TT and it seems a simple fit...but it doesn't work. I have contacted Baja and they don't know whats wrong. There was a product change recently so that might be the problem. Has anyone on here added the ignition switch to there bike?

Is there anyway you could send me a picture of the wiring and the key switch? Ill definitely do my best to help you

Share this post


Link to post
Share on other sites

Mark, it looks like Baja was on this faster than I could reach them. So, I'll follow this topic and see if a resolution presents itself. Otherwise, we'll happily return or exchange the part. Sorry for your troubles!

Share this post


Link to post
Share on other sites

I emailed Devin a picture of my turn signal etc switch on Jan 21. He told me he was stumped as he has never had this problem.

Share this post


Link to post
Share on other sites

Hasn't anyone added a key switch to their motorcycle? There are only two wires from the kill switch that get unplugged and then the two wires on the key switch plug into those spots. Very simple design and should work, but it doesn't. Any suggestions to get this to work?

Share this post


Link to post
Share on other sites

I did that already. Thanks though. I installed it the way the instructions say, then switched wires, plus a couple other ways. I am thinking that maybe its in the key switch. I would like to try another before I give up.

Share this post


Link to post
Share on other sites

Devon(sp) at Baja Designs talked me through a switch check with the multimeter. It works properly. So I will be installing it again but planning on taking a long time, checking every option I see. Fingers crossed

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×