Jump to content
Sign in to follow this  

Kx250 Wiring

Recommended Posts

hi guys.im having problems getting spark on my 88 kx250.the magneto was apparently refurbed and came seperate from the bike,connected to cdi box.The coil was also seprate.

basically theres four wires coming from mag that run to the cdi box.the wires are joined by push ins.now i would understand those to be correctly wired.then from cdi there are another two wires.they are a solid orange and a black with white stripe.

then on the coil i see it grounds by mounting to frame and also has a orange wire with a male push in.no other wires or adapters besides spark lead.

so i need to know were those 3 wires go?

thanks allot in advance

Edited by Rohan420

Share this post


Link to post
Share on other sites

I would pull up a wiring diagram for your bike, you should be able to find one easily enough online. Most OEM parts retailers have microfiche.

Share this post


Link to post
Share on other sites

i have looked a the kawa site but there components/wire coloirs arent spot on to what mine are?

Share this post


Link to post
Share on other sites

The two orange wires go together. The other black/white wire is for the kill switch.

this is a diagram for a 94, but should be close.

94wiringdiagram.jpg

Edited by Jeekinz

Share this post


Link to post
Share on other sites

Thanks man,i will try again.

Thing is those diagrams colours arent the same,i also have less wires.

But im sure those oranges go together...like jeekinz said.

Share this post


Link to post
Share on other sites

I have a 88 manual, but german. there's no orange wire, but Kawi is known for misprints, or maybe only US models have orange wires?

so what you discribe as orange is shown in black there (lead to ignition coil)

then there is a black/white from the magneto, also a black white to the CDI. they are connected and have another junction to the stop switch.

another 3 wires from magneto to CDI are white/green, white/red and black/yellow.

other than in the '94 wiring diagram, the pick up coil isn't particularly shown in the '88 diagram, so I can't say which colour is the pick up and which is the magneto.

but wait, I have also a '91 manual, which shows the white/green and white/red as pickup. the other two magneto wires have different colours and the ignition coil is orange...

hope that helps...

Edited by kawamaha
  • Like 1

Share this post


Link to post
Share on other sites

im gonna hook it up soon.could even be a bag or weak earth?the frame looks newly sprayed.maybe the spark plug coil is not grounding?or even motor to frame(quite unlikely id rate?

bad

Share this post


Link to post
Share on other sites

so you don't know if the components are ok?

at least you could measure the resistance of the ignition coil prim/sec.

and also the pickup and excitor coils...

  • Like 1

Share this post


Link to post
Share on other sites

measure resistance between (unplug CDI first)::

orange-ground,

spark plug wire-ground

black/white-black/yellow

white/green- white/red

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...