Jump to content
Sign in to follow this  

RM 250 no top end power!

Recommended Posts

2000 RM 250. Here is a vid of me riding it. It has great low end pickup but once i get in the higher rpms there is no power and i usually bog going up hill. I have new plug, 91 0ctane with 50:1 mix, cleaned carburetor, cleaned power valve, 155 main, 42 pilot, idk needle position, power valve setting is 180 degrees or half turn clockwise past 0 tension. Idk if that is the stock setting for my bike, i have heard 180 degrees or 1 full turn. All new seals and gaskets for bottom and top end. The second video is me testing to see if the power valve is actually functioning because all my MX friends said it was the power valve when they test rode it. Let me know what you guys think, thanks for the help.

https://www.youtube.com/watch?v=M_a1cb6qvA8

https://www.youtube.com/watch?v=_U6V2ox-ZCw

Share this post


Link to post
Share on other sites

2000 RM 250. Here is a vid of me riding it. It has great low end pickup but once i get in the higher rpms there is no power and i usually bog going up hill. I have new plug, 91 0ctane with 50:1 mix, cleaned carburetor, cleaned power valve, 155 main, 42 pilot, idk needle position, power valve setting is 180 degrees or half turn clockwise past 0 tension. Idk if that is the stock setting for my bike, i have heard 180 degrees or 1 full turn. All new seals and gaskets for bottom and top end. The second video is me testing to see if the power valve is actually functioning because all my MX friends said it was the power valve when they test rode it. Let me know what you guys think, thanks for the help.

https://www.youtube....?v=M_a1cb6qvA8

https://www.youtube....h?v=_U6V2ox-ZCw

I didn't really hear much bogging when I watched it the video.... sounded like you chop the throttle everyime the engine was about to come alive.

I must have missed something. You are idling down the hills... will it rev up going down the hill? Twist that throttle and ring that bikes neck! :D

:blink: I am pretty sure I missed something. I will watch the video again.

Edit: on the riding video at about 2:50 in... is that the bog you were referring too?

Edit #2: On this video I hear it more. :)http://youtu.be/RWzGGjLNQ7g Other should check this one out to hear what your are talking about.

Edited by RhinofromWA

Share this post


Link to post
Share on other sites

Rhino yea the 2nd video is my friend, he has been riding mx for years so he wasn't afraid to rev up the bike. I on the other hand am a new rider so i am still learning how to rev it out. But yes the second video is a more accurate example of what the bike is doing. And yes on the first video at 2:50 and a lil before i was 3rd gear pinned and it had no power going up the hill.

Share this post


Link to post
Share on other sites

I think your main jet is too small or a reed is cracked. I just fixed my powervalve. It wasn't opening at all, the linkage was unhooked. It ran way better than that. it would rev but it was like a bike setup for woods riding. All low end of course.

Share this post


Link to post
Share on other sites

I don't know the jetting on that bike, but the first thing I thought of was the stator timing for the lack of top end power. Also you did not say what your air screw is set at? I would try 1-3/4 on the air screw and start from there to fine tune.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×