Jump to content
Sign in to follow this  

1991 DR350S Issues in 5/6th on the highway

Recommended Posts

As the topic suggests, I am having issues with my DR350S at highway speeds in 5/6th gear.

I have never owned a dirtbike before and I am just learning alot with what the heck im doing!

So far i replaced the Carb with one from Keintech, and put a new spark plug in.

Just today I swapped the stock petcock with a Raptor 660 and completed the Airobx Mod while installing a new K&N Airfilter.

When i get up to around 6-7k+ rpm's the engine kicks a bit (maybe a misfire?) and i end up down shifting. Also i am having a TON of trouble finding neutral on this bike unless its not running.

So two things - What could be causing the issues at highway speeds?

And if i decide to redo the clutch, is it rather easy and innexspensive?

Lastly I was considering re-gearing since this will pretty much solely be used for street riding, what sizes are suggested?

Thanks!

Tim

Share this post


Link to post
Share on other sites

Not sure immediately what to suggest for your mis-fire but if you can't get neutral its almost always the clutch cable - even a well-oiled old one will "stretch" or stick enough to prevent the clutch disengaging properly. If your clutch lever will not work with a (strong) single finger then its time for a new cable, suggest a Suzuki one for best operation.

Just a thought :)

Share this post


Link to post
Share on other sites

Now the bike is sputtering and stalling when I slow down for red lights. I have a raptor 660 petcock on there but not sure if that's affecting this issue. The bike is also putting blackish stuff onto the rear fender from the exhaust. Does this mean its running lean?

Share this post


Link to post
Share on other sites

Ah no, classic signs of too rich!

But what is causing it..... suggest take the airfilter out first and try it for a short run.

Do you know what main jet is in the carb?

Is the carb showing any signs of leaking/overflowing?

Share this post


Link to post
Share on other sites

The carb is brand new and so is the air filter. I am thinking it's the fuel mixture screw. I have tried 1and 1/2 turns and other variations. Can't seem to get the bike to even idle now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×