EG295 Surging

Just got my first good ride on my 295. It runs fantastic, power everywhere and lots of it, but I'm a little baffled on this surging issue.

My jetting starting out:

48 pilot

NC3W needle middle clip position

178 main

Ran ok at first, but surged. I always thought surging indicated lean, so I kept going in on the air screw, but the surging got worse the further I turned it in. I went the other way and the air screw got a bit better, but didn't go away. So I went ahead and threw a 45 pilot in there and the surging improved, but still didn't dissapear. It's like the sirging wont go away, almost like I have an air leak. I'll check for air leaks but I don't think there is one. The power valve cover is leaking badly (I'll be calling EG on this), it can't suck air fron there can it?

Any ideas?

I'm at around 1000ft and it was in the mid 70's this weekend and low humidity.

Getting ready to put a 50 pilot and a 185 main,the bike just keeps running better and better with bigger jets. Im around 700 or so feet. My surging or what ever you call it happens when the throttle is chopped off.

Getting ready to put a 50 pilot and a 185 main,the bike just keeps running better and better with bigger jets. Im around 700 or so feet. My surging or what ever you call it happens when the throttle is chopped off.

Mine also, on decel and at idle. I guess I'll try going bigger on the piloy and see how that does.

Think the pilot is either 45 or 8, forgot now if i got a 50 or 55 to put in it,eric told me i was to lean. Working on two bikes on jetting,just can' t remember all those numbers....

Is this at a closed throttle? or just off, like at 1/8 throttle?

Mine is when you chop the throttle closed entering corners. Yeah i know quit letting off right!

I think mine is pretty much just at closed throttle also.

One other note on mine is that when the motor is cold (first start up) it doesn't surge at all. It starts surging after it's fully warmed up.

I chased this stupid problem for over a year with the 300 kit. I tried what is probably every brass/needle/slide combo in the entire reasonable range for that motor. Bigger pilot was the initial thinking as well, but like the OP, it yielded basically nothing. Air leak was the next idea. Went over the entire motor and intake and got every seal freshened up. Still surged and spooged like crazy.

I put a Lectron carb on the bike a few weeks ago on a total whim and it REALLY cleaned the jetting up. I wish I had done it a long time ago and saved myself the hassle. Less decel surge too. Not 100% gone, but certainely much improved over any jetting that I had come up with myself. I can jet a bike well, and this motor is one of the hardest to dial in - comparable to one of the early 2000's KTM 2-strokes before the head mods.

I THINK the spooging is better, but I have to put in fresh packing to verify.

Edited by GHILL28

Well, if the Lectron carb is what I need it will have to wait a little while. I'm hoping to get it running near perfect without it though. Also, I'm not having any real spooge issue, just the typical wet around the silencer tip that you'd expect.

Sounds like we have the same problems,after racing a few miles and its heated up full is when mine does it also. Hope my rejetting this time fixes it.i have no oil out of the muffler.

Sounds like we have the same problems,after racing a few miles and its heated up full is when mine does it also. Hope my rejetting this time fixes it.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now