Yz125 pipe/silencer years?

Ive got a question. Since the 98-2001 yz125 are "similar" to the 02-04 could i get a pipe and or silencer from the previous gen? Would it be a direct bolt on or no? Can anyone chime in on this?

i dont know for sure but i would think that it would fit. i know you can make a 06 exhaust fit but you have to mend it a little

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By faizakhtar125
      Hey guys I read an article saying that the 01 YZ125 has six gears. But other people are saying that it's 5. How many gears does it have? Just asking. Thanks.
    • By idratherberiding
      2006 YZ 250.. The manual calls for 10w30 (yamalube 4 stroke oil), can I use 10w50 (Motul semi sythetic 4 stroke oil) ??   I bought the bike, want to change the gear oil before I ride tomorrow but all I have at the moment is the Motul 10w50  semi synth.  Is that oil going to be too thick compared to the 10w30 or will it be fine..  Thanks
    • By faizakhtar125
      Hey guys I just wanted to show off my bike and show it to the world lol  What is your opinion on it. God or bad, please be honest. I am open to all comments and suggestions. Any upgrades I should do to make it look better and/or faster?

    • By Allooushh
      I bought a YZ250F yesterday and the previous owner said apparently it runs but they weren’t strong enough to kick it. I couldn’t kick while there so I took their word for it and bought it. I’ve been trying to get it to fire all day today, there are 2 chokes and I’m unsure if the air mixture is correct, so would be nice to know what I should do, it’s hard to adjust the air screw when the bike won’t even run. I noticed the spark is kinda low, I don’t know if it’s normally supposed to be like that or not. I can see a blue spark but it is very small and crappy, I’ve had thumpstars that generated stronger spark, I changed the plug it’s still the same, so maybe could be an electrical problem, the only ground connection I could find was for the ignition lead which I filed down to bare metal so I’m pretty sure that connection is good. Anything else I’m missing? It’s very hard to kick and I can feel the compression out of the exhaust so I don’t think compression is the issue.Just wanna know what I should do, haven’t owned a yz before so I could be not using the choke right or something. Thanks