kaulib russell's bike?

no this is his bike at amsoil ironman.

DSC05300.jpg

oooooooooooohhhhhhhhhhh

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Workerbee33

      I have a 2008 ktm 505 sxf, I am curious if anybody has installed the ktm hard parts fan kit or enduro engineering kit and if the mounting brackets work or did you have to fab something up? With a low output stator was it to much for your battery? Local ktm dealership says they think the 505 xcw fan kit will fit the 505 sxf...I do have an aftermarket tank
    • By To_the_holler
      Greetings
      I recently purchased a 2010 ktm 250 xcfw champions edition. (aren't all 2010s champions editions?) I am having a few issues with fuel and coolant that may be related.
      Relevant modifications: Previous owner had installed a quick shot 3, and an FMF F4.1, but claimed the bike had stock jetting (more on this later). Also claimed the bike got new piston and rings recently.
       
      First ride went mostly well. Exception being the bike needed an exceptionally long time (several minutes of riding with choke on) to warm up before it would idle with the choke off. Is that normal? That and I think the silencer was more of a loudener and practically made my ears bleed after a few hours.
      For the second ride I installed the factory silencer for everyone's sake and assumed the jetting would be fine since previous owner claimed it was stock. Bike ran fine until I came to a stop and noticed quite a bit of steam rolling out of the crank case vent hose.... Assuming the head gasket just went, I shut the bike off and called it quits.
      So I ordered and installed a new head gasket and lower cylinder gasket. Piston looked pretty new and so did the gaskets. I also could not find a "bad" spot on either gasket where coolant was making its way into the oil/crankcase. Here's where I may have messed up. When reinstalling the timing chain tensioner,  I don't think it properly "clicked" back into place because the bike would not run after reassembly. I pulled the valve cover to find the exhaust cam had skipped 1 tooth.  So I reset that and was more aggressive with the tensioner and got it to properly seat. Bike fired right up and seemed to be ok compression wise. I put new oil in, rode it for 5 minutes and then changed it again to somewhat flush out the coolant contaminates.
      Does anyone think the piston struck any valves if they were only 1 tooth off? Wouldn't I have heard them clank together when trying to start it or felt the extra resistance when kicking it over? (Bad battery at the time so no electric start)
      Took it out for a third ride with new head gasket and fresh oil and it seemed harder to start and wouldn't idle properly with or without choke. After gently riding it for several minutes it would still not run properly. It had a surging idle and would sporadically die. If throttle was applied it would sometimes respond or sometimes die. Then I noticed the steam beginning to exit the crank case vent hose again. It seemed to run ok anywhere above 1/4 to 1/2 throttle. Great power response and felt smooth. Anything less and it was dying or surging up and down.
      So I installed a new water pump shaft seal, and side cover gasket hoping that was the cause of the coolant leak. Then I went after the carb to see if something had become clogged. A complete disassembly and cleaning revealed a surprisingly clean carb with the following jets: #172 main jet, #45 idle jet, and #85 starter jet. Needle jet clip was on the 5th position from the bottom. Nothing seemed to be clogged or malfunctioning.  I inspected the intake boots for cracks/leaks and everything seemed to be fine there. After reassembly there was no improvement. I then tried every combination of air screw and qs3 adjustment possible which didn't seem to even phase it. The only thing different I noticed is after several minutes of poorly running and attempting to tune it, if I put the choke back on it would almost instantly begin to rev up uncontrollably high until I turned the choke back off.  And then to top it off I still have steam coming out of the crank case vent. I'm hoping the steam is somehow leftover coolant from before and not something like a cracked head or anything. I gave the head a good look over when I had it off for the head gasket but I wasn't really looking for cracks back then. 
       
      Any ideas on where to go next? Could these issues somehow be related?
       
      Sorry for the giant wall of text but if you made it this far thank you. Any thoughts, ideas, jokes are welcome. 
    • By prorider17
      For sale is a new right-side OEM radiator + cap from my 2015 Husqvarna FC450. Could possibly fit 2015 KTM 450SX-F (since it's the same bike, but in orange).
      Asking $60 + cost of shipping. Photos: https://photos.app.goo.gl/pvVqTcrMeczQhHaf1
       
    • By KyleHubert
      Hey guys, what do you think would be a fair selling price for a 2015 ktm 250xcfw? It only has just 15 hours on it.. as i mangled my back and haven't been able to ride since. 
    • By johnny125aao
      So i was about to get a crf250r until i went to the ktm dealership and checked out a 2017 ktm 250sxf. i just wanted to know what thoughts people had on these bikes. I have always ridden honda but would like to know more about the ktm. reliability, handling, resale, and any known problems .