FE450 Brakelight Problem

Hey all,

So I have a 2011 Husaberg FE450 with a brakelight instead of a tail light. I don't know if they came from the factory with a brakelight or what. Anyway, something is wrong with the wiring. Sometimes the light turns on and off, something like flickering. Also whenever I press the brake it doesn't light up. Any ideas? I think I have narrowed down the location of the problem to the jumble of wiring under the seat by the battery. Does anyone have a wiring schematic or something to see what fuses/ wires go to/come from where?

Thanks

Hey all,

So I have a 2011 Husaberg FE450 with a brakelight instead of a tail light. I don't know if they came from the factory with a brakelight or what. Anyway, something is wrong with the wiring. Sometimes the light turns on and off, something like flickering. Also whenever I press the brake it doesn't light up. Any ideas? I think I have narrowed down the location of the problem to the jumble of wiring under the seat by the battery. Does anyone have a wiring schematic or something to see what fuses/ wires go to/come from where?

Thanks

Yes they come from the factory with the brake light. I will check my manual from my 2010 to see what fuse it is (there the same). Most likely, you have a short in the fuse, so simple fix.

Thank you! But you i found the source of the problem. The wire for the sensor is hidden under the brake lever...i traced it and found the it was just a loose connector :)

Thanks

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now