Jump to content
Sign in to follow this  

DRZ400S FCR Problems

Recommended Posts

So I bought a used E-Model FCR from another TT member and finally got around to installing it the other day. I turned the petcock to prime to fill the carb and gas started coming out of the float bowl seal. I cleaned up for the night and decided too look at again the next day. I come back and the leak had completely stopped. The bike currently starts with max choke and when it get warm and I take the choke off it idle like crap and stalls. If I give it throttle it bogs really hard and stalls unless i give it more then almost full throttle.

My bike setup 01 DRZ400S

e-model cams

Yoshimura debaffled RS3 slip-on

UNI air filter

deCaliforniacation

3x3(closer to 3x4) Mod

Here is the carb setup..

Freshly Cleaned carb

Eddie mod done

TPS Removed

EMN Needle in the 3rd clip position from the top

Coast Enricher removed

Pilot air jet removed

160 main jet

200 main air jet

45 pilot jet

R&D Flex jet 2 turns out

3x3(closer to 3x4) Mod

Sudco Carb Adapter

Edited by WonTian

Share this post


Link to post
Share on other sites

FCR carb from a DRZ400E, you definitely need a pilot air jet. With the CE removed and the side nipple sealed, you need a 100 pilot air jet. The other jetting looks OK.

You may have other problems but hard to tell until you fix the air jet. Verify the slide plate is not up side down. As you open the throttle, light appears under the center not the sides.

Share this post


Link to post
Share on other sites

Thanks for the reply. I'll try to get a hold of one tomorrow when the shops are open.

The slide plate is kind of arrow shaped. I put the plate in pointing up. Is that correct?

Share this post


Link to post
Share on other sites

Yes. The "arrow point" points up. The rubber seal between the slide plate and the roller slide needs to be in good condition also.

Share this post


Link to post
Share on other sites

It seemed fine when I had it out but I'll double check since the carb has to come out to fit the air jet

Share this post


Link to post
Share on other sites

Yes...install a pilot air jet for sure........Also could be Pilot jet clogged or slide plate issue...

Are you running it on prime?

Did the previous owner give you a plausible reason for selling it.?..The carb may have an underlying issue...

Share this post


Link to post
Share on other sites

I'll double check the slide when I have the carb out.

It's running on "On"

I think he was selling because he bought a 41mm carb for his big bore

Edited by WonTian

Share this post


Link to post
Share on other sites

I pulled the carb and snapped some pics

9251378524_f09ddcb60f_b.jpg

9251378796_126e36ff70_b.jpg

9248599183_db34e371c7_b.jpg

9251378610_b1f98336dd_b.jpg

9251378916_f3cd18eeff_b.jpg

9251378748_872cf5b61a_b.jpg

9248598651_b6cd655d1e_b.jpg

Here is the AP video

Share this post


Link to post
Share on other sites

All good except the AP looks late and excessively long. I have never really understood the wire mod to the pump. Can't advise you much on that. I would like to see it earlier and shorter by limiting the duration with pump stroke. But it may not be a problem at all.

Share this post


Link to post
Share on other sites

So I popped the 50(60?) PAJ back in just for a trial run. I screwed the mixture screw all the way in and backed the idle out and the bike now idles and runs. It smells kind of lean and pops a little bit on decel but when I richen the mixture it drops the idle. So I'm leaving it screwed all the way in at the moment and I have a 100 PAJ on the way. But the bike is now rideable

How do I fix the issues with the AP?

Edited by WonTian

Share this post


Link to post
Share on other sites

i would also like to know how do you shorten squirting time?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...