Jump to content
Sign in to follow this  

DR350 doesn't seem to run with speedo harness disconnected...

Recommended Posts

Hello all.

I have a 1990 DR350 street model that I am converting to dirt. I call it the singularity, as it is an absolute black hole for money...

The bike has the speedo and tach on it right now, but it is broken and I want to remove it in favor of a small riding bag to hold my cigarettes and such.

The problem is, when I disconnect the blue plug whch has all the wires that go to the speedo assembly, the bike dies. I cannot figure out what the deal is here. I have removed the key switch and all is well on that front.

From looking at a wiring diagram, it looks like I may have to bypass the neutral indicator or maybe relocate it and cut the orange wire from the tach, but alas I really have no idea and this has got me a little stumped.

I know I'm not the first person ever to try and remove the speedo assembly from one of these bikes, so here I am. Maybe one of you more experienced DR owners can help me out. I sincerely appreciate any help I can get.

Share this post


Link to post
Share on other sites

my bike wont start without the neutral light hooked up so you might need to bypass it on yours

Share this post


Link to post
Share on other sites

Hello everyone! I finally got my bike back together and tried unplugging the speedo assembly again. It still starts and runs fine.

The only problem is that the kill button stopped working, but I imagine that should be easy enough to fix.

I don't know what I had been thinking before. :thinking:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...