Jump to content
Sign in to follow this  

Does this sound like a jetting issue?

Recommended Posts

I have an 02 yz 125 and it's been running great until a couple days ago. It's spitting out a lot of that black stuff out of the pipe. It also sputters and bogs in high rpms. It's low end is great but when you pin it, it has nothing and just sounds like it wants to die. What do you guys think?

*edit: I did adjust the idle by turning the air/fule screw. Would that affect my jetting at all? Sorry, not too familiar with 2 stroke jetting.

Edited by YzShelby394

Share this post


Link to post
Share on other sites

I did adjust the idle screw a few days ago as my bike would not idle. It idles great now but not running so great.

Edited by YzShelby394

Share this post


Link to post
Share on other sites

Is that causing it though? I'm pretty sure they've been changed since then.

Either you know they have, are you are hoping and guessing they have.

Do a leak down test to be sure.

As mentioned, you jetting CANNOT change on it's own inside the carb.

Share this post


Link to post
Share on other sites

Either you know they have, are you are hoping and guessing they have.

Do a leak down test to be sure.

As mentioned, you jetting CANNOT change on it's own inside the carb.

I wasn't sure if messing with the air/fuel screw would affect the jetting in any way. Sorry, don't know much about 2 stroke jetting.

Edited by YzShelby394

Share this post


Link to post
Share on other sites

I wasn't sure if messing with the air/fuel screw would affect the jetting in any way. Sorry, don't know much about 2 stroke jetting.

The air fuel screw adjusts the pilot circuit, that is all. That is why you adjust it while idling, for the highest idle.

Share this post


Link to post
Share on other sites

The air fuel screw adjusts the pilot circuit, that is all. That is why you adjust it while idling, for the highest idle.

So it's definitely not jetting? Just wanna be sure before I pull the carb off

Share this post


Link to post
Share on other sites

dude, you need to do a LEAK DOWN TEST before you do anything.

Alright I'll do that. The top end is fresh so I hope all is good there.

Share this post


Link to post
Share on other sites

Similar thing happened to a friend. Grounding wire on frame had come loose ( I think on the voltage regulator, not sure). It was backfiring and pouring out black smoke. .

Share this post


Link to post
Share on other sites

Forgot to post after I found out the problem. When I pulled the carb of to see if any dirt got in there, the main jet was just laying in the bowl not screwed in to anything lol. Anyhow she runs fine now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...