Jump to content
Sign in to follow this  

RMZ-250 rebuild project - wont start

Recommended Posts

Hi!

This is my first post so please forgive me if I am posting in the wrong area.

So I picked up a 2007 RMZ 250 last weekend as a simple project / flip bike. The owner informed me that the bike had low compression so he had his mechanic replace the piston, rings and he put on a new cyclander. The bike has great compression right now. However, the guy I bought it from did not have the time to complete the project. I checked the valves and they were way to tight, meaning the smallest guage didnt even fit! I put in new shims and is is currently in spec. I adjusted the timing and it also is in spec. I changed all the fluids, filters and added a new spark plug.

The bike has great compression but it wont start. I removed the carb, added new jets and cleaned it. Still nothing. When I kick it seems like its not even trying to start.

Also, while kicking it is very smooth, nothing to be worried about with tons of compression. Im thinking it could be carb related or possibly something with the electrical system.

Does anyone have any tips or suggestions for me?

Thank you!

Share this post


Link to post
Share on other sites

Hi!

This is my first post so please forgive me if I am posting in the wrong area.

So I picked up a 2007 RMZ 250 last weekend as a simple project / flip bike. The owner informed me that the bike had low compression so he had his mechanic replace the piston, rings and he put on a new cyclander. The bike has great compression right now. However, the guy I bought it from did not have the time to complete the project. I checked the valves and they were way to tight, meaning the smallest guage didnt even fit! I put in new shims and is is currently in spec. I adjusted the timing and it also is in spec. I changed all the fluids, filters and added a new spark plug.

The bike has great compression but it wont start. I removed the carb, added new jets and cleaned it. Still nothing. When I kick it seems like its not even trying to start.

Also, while kicking it is very smooth, nothing to be worried about with tons of compression. Im thinking it could be carb related or possibly something with the electrical system.

Does anyone have any tips or suggestions for me?

Thank you!

by any chance have you verified that you have spark? if you do have good compression, spark and fuel then it can be your timing is off. there have been some instances where the stator has sheared the woodruf key on the shaft makeing it out of time.

Edited by funkinalive

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...