Jump to content
Sign in to follow this  

Why is my RMZ making a clicking noise?

Recommended Posts

Hello guys, I have recently purchased and installed a Yoshimura RS4 full system on my 2012 RMZ 450. I have realized after putting it on its running really hot and after I shut it off its making a clicking noise (like what a car sounds like after its been shut off) What is the reason for this happening?

Thanks,

Wyatt

Share this post


Link to post
Share on other sites

I was under the impression that the clicking noise cars make is metal contracting as it cools down. Sounds like you have an overheating issue from running lean. I'd throw the stock pipe back on and see if it runs cooler just to rule out that u didn't mess something up.

If it runs fine put the aftermarket pipe back on with the grey (rich) coupler. If it still is running hot you'll need a fi tuner cuz she seems to be running lean.

If your still having problems let me know. I know these bikes like the back of my hand and built tons of em, as you can see in my default pic. More than happy to help you out...

Edited by Mx Factory USA

Share this post


Link to post
Share on other sites
I was under the impression that the clicking noise cars make is metal contracting as it cools down. Sounds like you have an overheating issue from running lean. I'd throw the stock pipe back on and see if it runs cooler just to rule out that u didn't mess something up.

If it runs fine put the aftermarket pipe back on with the grey (rich) coupler. If it still is running hot you'll need a fi tuner cuz she seems to be running lean.

If your still having problems let me know. I know these bikes like the back of my hand and built tons of em, as you can see in my default pic. More than happy to help you out...

Ok thank you, I will try the coupler first, don't really have the time to take off the pipe right now. I'll see what if at any difference it will make.

Thanks,

Wyatt

Share this post


Link to post
Share on other sites

It'll be fine with or without the coupler i'd imagine mate. That ticking noise as a result of cooling is perfectly fine. Every bike 4st I've come across had done it, if you ride it right 😉

Share this post


Link to post
Share on other sites

My 250 does it and my honda used to do it a lot too. It's the sound of material contracting as it cools, as it does not have a continuous heat source any more. Heat makes metal expand, when it cools it contracts and clicks. 4 strokes run hot as blazes there's no other way to slice it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...