Jump to content
Sign in to follow this  

inconsistent te510 help !

Recommended Posts

so I go out riding yesterday its running like new power wheelies in high gear no backfire or even pops etc no probs.Then I take it out today its got low rpm 3000 kinda gurgle and pop then goes find high in the rev range.I have the pu kit fitted arrow pipe etc o2 sensor out and bung in place it has a kn airfilter which I cleaned and oil still same.Is this consistency maybe because the airbox hasn't been opened up I feel its running rich that's why does little gurgle/back fire etc but only does this one day then next day its sweet.Has anyone has this problem and can help to get it running sweet every time or opinions thx

Share this post


Link to post
Share on other sites

That would not be an airbox problem. It could be a short somewhere in the wiring or a clogged fuel injector.

Share this post


Link to post
Share on other sites

It's possible that a clogged injector would cause it to run inconsistently. If I had to guess I would say it needs ECU tuning.

Edited by fasterman
  • Like 1

Share this post


Link to post
Share on other sites

I know we have had a few PMs and I tried to think what might help you, but I never asked if you might have bad gas in it? Bad gas can make these bikes run like shit!!

  • Like 1

Share this post


Link to post
Share on other sites

thx mate well I did think it may have been the gas I always use high octane but I put vortex in it which is Caltex fuels high octane fuel and it was flying like normal even descent power wheelie 4th gear.But then it did same issue as before so im really thinking it is electrical ive checked what I can but im limited in knowledge and surely there are wires everywhere under tank etc.ps all the high octane fuels here are 98 octane and previous user used same fuel

Share this post


Link to post
Share on other sites

Fuel pump?? If the pump is slowing dying then the pressure is low resulting in inconsistent running. Also check the spark plug boot to wire as this is a common separation and water shorting. While there di-electric grease ALL connectors and tape the wire to spark plug boot!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...