Jump to content
Sign in to follow this  

Oil level question help!

Recommended Posts

I just changed the oil on my bike let it all drain out and I filled it up with the amount it needed but on the sight glass it says it's high? I don't understand why I think it's fine since I put the right amount in just thought I would make sure with others.

Share this post


Link to post
Share on other sites

Not a problem. The oil sits in the right side until it flows or gets pumped to the left. Once you start it, it will level out. Also remember to run the motor to warm the bike up before your next oil change.

I usually take the waste oil and measure the volume with a ratio-rite before I dump it in the waste jug to make sure I know how much is coming out vs. how much I am putting back in. Just a habit, but it's easy, and it gives me peace of mind that the oil isn't going anywhere.

Once I put 20W oil in by mistake (Kawi Red jug looks the same as 10W . . . picked it up at the dealer . . . what a waste, but good for the lawn mower) anyway, I went to drain the bike and it took a looooooong time. That's how I know the oil has to work it's way over to the left.

So, ride it. Check the glass to see where the oil line is. If still way too high, just run it. Next oil change, warm up first, then dump the oil and measure. Then put the recommended amount back in anyway and be done with it.

The glass basically tells you oil is there. It is not a precise measurement. What is a precise measurement is the torque on that drain bolt. Know it and don't exceed it. Stripping that is a big pain to deal with.

Share this post


Link to post
Share on other sites

Dragon, what is your procedure to checking level, my bike is new 16 hrs and i seem to be losing about 100 ml every 3 hrs of riding.

Share this post


Link to post
Share on other sites
Any of you have a problem with the drain bolt? So far all it seems to do is leak and it's not striped

Do you have the aluminum (sometimes brass) crush washer on it?

Share this post


Link to post
Share on other sites

Any of you have a problem with the drain bolt? So far all it seems to do is leak and it's not striped

I bought a whole box of copper washers from harbor freight and use those for the drain plug. I can re use them two or three times. Aluminum is probably cheaper. That will solve the leaks.

Share this post


Link to post
Share on other sites

Dragon, what is your procedure to checking level, my bike is new 16 hrs and i seem to be losing about 100 ml every 3 hrs of riding.

That's a lot. We had the same problem on our new-to-us 2011. It turned out to be the o-ring that goes between the cam cap and the cylinder head at the spark plug hole. It wasn't there! Your o-ring may just be leaking. In any event, the way I measure is as I said. Make sure you warm up the motor before draining and make sure you drain all the oil. Then measure the 750-800 ml with the ratio rite and run it. Since we change the oil every couple of hours anyway, it was not usually a problem. I did add oil once or twice if the level dropped below the glass. It isn't that the glass is useless, just that it's very sensitive to level and won't be accurate immediately after filling up. When I decided to replace the valves, I dropped in a new o-ring and the problem was solved. Hope that helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...