Jump to content
Sign in to follow this  

Keihin FCR 41-MX accelrator pump prob..

Recommended Posts

Hello guys,

I just bought new (used) FCR 41-MX and I was doing o-ring mod... Then I noticed this: Does my accelrator pump work right? I haven't done anything to it....

Share this post


Link to post
Share on other sites

The pump rod is not 'snapped in' to the black plastic cam.

You should not be twisting the timing screw indescriminately. The AP will be all out of wack in raltion to the slide p[osition, You need to reinitialze it now. Follow the procedure in the manual.

Share this post


Link to post
Share on other sites

The pump rod that snaps into the black plastic cam part is not snapped in all the way.

It is a friction fit. You have to take a pair of plier and 'push' hard once, on the rod, pushing up into the carb body. You will feel it 'click' into place.

http://www.dirtrider.com/features/protips/141_0707_keihin_fcr_carb_rebuild/

Share this post


Link to post
Share on other sites

You asked if the AC pump works correctly. The best way to check that is to check the fuel squirt. The squirt should be one second or a little less, solid stream, and just miss the bottom of the slide as it lifts up.

Share this post


Link to post
Share on other sites

Yeah I try it right away when I get home...

In Finnish forums, someone said that in Honda's AC pump model "film" is limited version and KTM's model is "free". That's why KTM drivers put Honda's FCR film and rod, because KTM's AC pump squirts too long...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...