Jump to content
Sign in to follow this  

My son's smoky KX65

Recommended Posts

Sorry the vid is sideways, but you'll get the idea.

So far I've rebuilt the carb, repacked the muffler, adjusted the needle jet moving the clip up 1, and tried adjusting the float. Starts up cold well & as you can see - doesn't really smoke much when at idle. I'm running an iridium 9 plug & the premix is 32:1 per spec. Obviously, I haven't fixed the problem 🙂

Doesn't appear to be losing any coolant, although I'm not 100 percent sure about the trans oil. It doesn't SEEM like it's losing any & the plugs aren't fouling. Jetting is stock, as it was just rebuild with a Moose kit.

All other repairs past this one get a bit bigger so I'd love to get someone's (more) educated opinion before getting into it/them.

Help? Thanks - Tim

20130711 123547 - YouTube

__________________

Edited by heypilch

Share this post


Link to post
Share on other sites

It doesn't look all that bad to me. Most of them will smoke a bit more than normal when revved up and back to idle, especially when the motor isn't fully warmed up. Did it not used to be like that and now smoking more than before? Or always like that?

Share this post


Link to post
Share on other sites

There is nothing wrong there. Looks like a perfect 32:1 mix to me.

Here's our 250. Warm motor, warm day, 40:1, tuned perfectly. And yes I was enjoying the smell.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...