Jump to content
Sign in to follow this  

Throttle sticking closed

Recommended Posts

So it started last weekend at a race. I felt a little notchy feel in at the first crack of the throttle. I tore it apart to clean it all out and all was good when I put it back together. The next day I cracked it open and heard a click coming from the handle bar area and it stuck open. Tore it back apart and I did not see anything. Cracked it on and off a bunch of times and there were no problems throughout the whole day. Washed the bike and noticed the notchy feel again. Tore into it and cleaned it again and did not notice anything out of the norm until i cracked it open while the cover was on and the screw was holding the plastic piece open. It would intermittently stick closed until you moved the throttle around and it will unstick itself. I am not seeing anything out of the norm in the housing so I will be cracking open the carb and see if I got something sticking in there.Any suggestions would be great. It is a 13 250sx and the recall is done. Here is a video.

Share this post


Link to post
Share on other sites

There is a recall on the 2013 throttle housing innards. Check with your dealer immediately if you are unsure if the recalled parts have been replaced.

Share this post


Link to post
Share on other sites

Maybe the cable in the housing is starting to break. Individual strands start breaking and can cause the cable to bind up. Disconnect the throttle cable at both ends and see if you can slide the cable back and forth without any binding.

Share this post


Link to post
Share on other sites

My 300 did the same thing right after the draler replaced the throttle parts. I couldnt find anything wrong when I took it apart but have not had a problem since. If you find something please post because I am interested in what the problem is. Good luck.

Share this post


Link to post
Share on other sites

I experienced a very similar disconcerting "locking" of the throttle when opening it on my 2013 200xc-w when it was new to me (I bought it used). This happened to me enough times on my first few rides that I posted something about it here. Hasn't happened since. Strange...

https://thumpertalk.com/topic/1020518-recall-on-husaberg-and-ktm-2-strokes-must-read/#entry10793781

  • Like 1

Share this post


Link to post
Share on other sites
I experienced a very similar disconcerting "locking" of the throttle when opening it on my 2013 200xc-w when it was new to me (I bought it used). This happened to me enough times on my first few rides that I posted something about it here. Hasn't happened since. Strange...

https://thumpertalk.com/topic/1020518-recall-on-husaberg-and-ktm-2-strokes-must-read/#entry10793781

exactly what I am feeling. I got a new cable and the carb is apart. Nothing out of the norm so I will reassemble. If it still happens I will buy a g2 throttle.

Share this post


Link to post
Share on other sites

Well I went out and bought a motion pro cable and reinstalled everything and all is good and a ton smoother than before. I think that the plastic piece on the spring was not seated in the slide unfortunately I was unable to actually visually see it. One thing I did notice though was that some water was getting into the carb from the throttle cable into the carb. I resided the boot because it was bigger and threw some silicone on top of the boot hopefully preventing that from happening again. Thanks for the help everyone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...