Jump to content
Sign in to follow this  

All Suzuki RMZ250 2012 Bike Won't Idle Help

Recommended Posts

Hi, I replaced the top end on my 2012 bike with a Vertex 13:5:1 piston. I can start bike with choke on, runs nicely with chock on however, when I push choke in the bike won't idle. I have adjusted throttle still won't idle, adjusted idle clickers six and half turns out and more at times still won't idle. I can start bike on choke, give a little throttle, turn choke off, making sure I have a little throttle on, than when I let throttle off, it won't idle and stalls. I have swapped efi mapping plugs to the richer plug, still no good. Any suggestions??? Is the piston too tight??? so bike won't idle, do I need to attach an aftermarket fuel mapping system???

Can anyone help I'm desperate to fix I have a race soon

Share this post


Link to post
Share on other sites

It is possible that it could be the wrong size piston, yes it is probably too tight. Oem spec piston is the way to go. Oem pistons usually last longer too.

  • Like 1

Share this post


Link to post
Share on other sites

Wait, did you heat cycle it? Idle it for 3 minutes or whatever you have to do to run it for a few min, let it cool down completely. Then go ride it for like 15, cool it down all the way and then rip it, cool it down. Should be good. You have to set the ring.

  • Like 1

Share this post


Link to post
Share on other sites

Hi, I replaced the top end on my 2012 bike with a Vertex 13:5:1 piston. I can start bike with choke on, runs nicely with chock on however, when I push choke in the bike won't idle. I have adjusted throttle still won't idle, adjusted idle clickers six and half turns out and more at times still won't idle. I can start bike on choke, give a little throttle, turn choke off, making sure I have a little throttle on, than when I let throttle off, it won't idle and stalls. I have swapped efi mapping plugs to the richer plug, still no good. Any suggestions??? Is the piston too tight??? so bike won't idle, do I need to attach an aftermarket fuel mapping system???

Can anyone help I'm desperate to fix I have a race soon

not sure if the High Comp piston is the issue here. i replaced my piston with a standard size and compression wiseco kit and it started and idled absolutely fine.

  • Like 1

Share this post


Link to post
Share on other sites

Sounds like TPS bumped or disconnected. Betting on electrical issue. Good luck. Go over everything.Make sure all plugs are good. Check throttle operation. Check voltage of tps. If you can't check this stuff,load it up and take to a good dealer. They will have it fixed in no time.

  • Like 1

Share this post


Link to post
Share on other sites

Hi all,

thanks for all comments, its bucketing down with rain here, will take out tomorrow, run for 15 minutes, cool down to seat the rings, hopefully it works, if not will work through other comments, i will keep you posted

Share this post


Link to post
Share on other sites

Screw in your idle until it will idle on its own, with that electronic choke/idle it can be tricky. I have a 2010 and so does my buddy, his did the same exact thing your explaining. I turned the idle up until it idled normally without the choke. Make sure your at least running 50 % rave gas with that high compression piston.

Share this post


Link to post
Share on other sites

hi all,

i took bike out for a ride today, ran the bike for 30 minutes, still won't idle. Because bike was warm I used hot start lever and it started without choke, but once i let lever off it stalled again, so i again started bike with hot start lever on and then i back off lever until it stalled. So i rode back to trailer and adjusted hot start lever out so it took up the slack of the cable and blow me down, it runs and idles like a new bike, i'm over the moon, rapped i worked it out, thanks all for your help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...