need help on yz 125 ASAP

i just bought a yz125 a couple days ago and it has spark and gas but it just wont run. Ithink there is something wrong with the power valves but im not sure. I NEED HELP, thank you

I'd start with a compression check and go from there.

Even if the Powervalve is broke, it will still start. As Darvo said, check compression. Make sure you've got fresh gas mixed at close to 40:1.

 

Pretty rare, but my YZ (1 think 2001, back in 2001) blew the head o'rings and coolant leaked into the cylinder and no start. Check coolant is full. Low-level might indicate you have blown head gasket/o'rings/this uncommon problem.

Well, assuming it has compression. 2 stroke only needs 3 things to start. fuel, air, and spark. you said it has spark, so check that off the list. 

 

Fuel- first step, make sure there is gas in the tank. 2nd step, pull the carb bowl off, see if its filled with gas, while your at it, clean the the carb. 

 

If that all check out, look for any possible air leaks (which it should still start even with a small leak more than likely)

 

if it still doesnt start, i would pull the head off and look for coolant leaks etc. 

 

 

i just put fresh gas in it when i got it and  i cleaned and mixed the gas  40:1, i checked for cracks and there are none what so ever. and i just put a new piston and ring in it, there is also very very good compression. there are no coolant leaks either. 

How is the compression in numbers like PSI? Have a look if you get a spark too.

i just put fresh gas in it when i got it and  i cleaned and mixed the gas  40:1, i checked for cracks and there are none what so ever. and i just put a new piston and ring in it, there is also very very good compression. there are no coolant leaks either. 

 

When you put the new piston and ring in - did you check to make sure the powervalve is working properly?  How did the cylinder look?

 

You say it has gas - gas in the tank?  Is gas making it to the spark plug?

Another rare occupancy was in my old 98 rm 125, the wrist pin bearing shattered after I started it. I thought it just Stalled. It'd kick over but wouldn't start.

I recommend tearing the jug off and taking a look.

For the record, I don't think this is your problem. I'm just saying tear it down and see.

Darvo, im pretty sure that is what is wrong with it is the power valves. i have worked on a lot of 2 strokes but i have never played with the powers or jetting. its probably the power valves, but im not sure

there was gas going to plug till i took the carb off and cleaned it and now there is nothing. and jrod the wrist pin is fine and i have tore it down and checked everything all the way down to the crank and crank seals. everything on the bottom half of the motor is fine. im pretty sure its all in the power valves. I have a question in order for it to run do you have to have a kill switch?? Because im getting bright blue spark

Even with a bad power valve it would at least cough or sputter for you. If you're getting spark than I wouldn't worry about a kill switch. If you lean the bike over for a bit , does gas leak out of the float vent? It sounds to me like you're not getting any fuel. Either your float is stuck closed or your pilot jet is clogged.

Also, since you said you looked at it all the way down to the crank seals, make sure your flywheel is installed properly with the key in place.

it wont dont anything if you kick it but if you push it it coughs. what is the screw for in the back of the carb?? and the flywheel is in where its suppose to be. when you lean it over there is gas that comes out of the float vent.

it wont dont anything if you kick it but if you push it it coughs. what is the screw for in the back of the carb?? and the flywheel is in where its suppose to be. when you lean it over there is gas that comes out of the float vent.

if you're referring to the small straight slot brass screw above the bowl, its the air/fuel adjustment screw. Turn it all the way in, then 1.5 turns out.

what is the allen screw for with the screen??

what is the allen screw for with the screen??

can you post a pic?

Darvo, im pretty sure that is what is wrong with it is the power valves. i have worked on a lot of 2 strokes but i have never played with the powers or jetting. its probably the power valves, but im not sure

 

It's not the power valves. Even with the power valves out of time or siezed the engine should start and run, but it will lack acceleration. You need to stop guessing, and systematically approach your no start issue step by step starting with the basics. 1) do you have spark and a new plug ?  Are you getting fuel into the carb bowl ? Try using starting fluid and see if the engine starts. I also highly recommend you do a REAL compression test with a guage. Your comment the compression "feels very very good" in fact could only be 90 psi as read by a gage. You need about 150 psi to show a healthy top end. Anything below 100 and the engine won't start.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now