Idle won't settle down during a ride. Also bar mounts bend easily

Problem 1: Idle

 

My wr250 idles great when you start it but during a ride if you stop the bike or let off the throttle to coast the idle doesn't drop imediately like it should.  Instead it goes down in stages and takes a few minutes to finally settle at a normal idle.  If you shut down the engine and resart it then it is fine again.

 

The pilot jet is stock and clean and the problem only happens when the bike is being ridden and then you try to drop it to an idle. 

 

My gear oil has also been going a milky color but I'm not sure if this is my worn clutch basket or water in the oil.

 

I'm thinking vacumn leak?  Coolant leak?  But I don't know how to check for this.

 

 

Problem 2: Bar mounts bent

 

My son and I both have the same bike.  WR250 2007/2008.  If the bike falls over the handle bar mounts bend.  Loosening the nut under the mount straitens them a bit but not fully back to normal.  I think the rubber bushings that the two mount bolts go through are squished and if replaced would straighten then up again?  But they seems to bend out of line so easily I am hoping there is a better system.  Or do I just buy a bunch of the rubber bushings and replace them every few wipe outs?

 

 

 

 

 

Hi,

 

 does you son's bike behave at all like this..??,

 

 

  re- oil contimination, dump the gear oil + let it sit in a clear jug / glass,

 

 water will settle out,

 metal filings will sink,

 

 Charlie

I'll do the glass jar check.  Tks. 

 

My sons bike does not have an unstead idle like mine.  I have tried cranking the throttle to unstick it with no success and putting it in gear with half clutch to slow it down but it just speeds up again.  The only way to settle it down is to shut down the bike and wait a few minutes then restart.

 

 

I'll do the glass jar check.  Tks. 

 

My sons bike does not have an unstead idle like mine.  I have tried cranking the throttle to unstick it with no success and putting it in gear with half clutch to slow it down but it just speeds up again.  The only way to settle it down is to shut down the bike and wait a few minutes then restart.

 

 

OK,

 sounds like an  air leak,  - something expands and lets air  in,

 

 have you re-sealed the reed cage?,

 that IS a common leak point.. SOME brand new bikes ( 250 + 300) nip-up with the weak mixture brought about by this!,

 

Charlie

I'll check the reed case.  Is there a way to check if the leak is through the carborator intake (reeds etc) or if it is in the block (coolant/combution chamber).  I'm going to check if there is water getting in the oil.

I also have a wr250 but 06 model, once bike is started and warm it idles and fires just fine but once has been ridin as soon as I stop in neutral it will turn off, have adjusted the idle but still same prob, some times bike will rev even when I haven't put Te throttle on.

hi again,

 any luck pinning down the oil contamination?,

 

 check the coolant levels in the RAD,

 

 you COULD be drawing water in fron stream crossings via the crank / gearbox vent line,

 

 Charlie

Brp sells  solid bar mounts that will help with the handlebar twisting

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now