Jump to content
Sign in to follow this  

08 YZ250F running crappy, Help!

Recommended Posts

hey guys just picked up 08 yz250f real cheap cuz it runs terrible (only starts with choke, revs real high, stalls when you give gas). thought it was clogged up carb cuz its been sitting for a year the guy said. took carb off and not clogged at all. I do know the gas is super super stale though you can smell it. Anyway long story, i lost the a jet so cant put it back together yet lol, but i have another one coming in mail. Could it only be the stale gas?? I hope so. Or should i try the plug too?? let me know thanks.

Share this post


Link to post
Share on other sites

hey guys just picked up an 08 yz250f real cheap cuz it runs terrible (only starts with choke, revs real high with varying rpm, stalls when you give gas). thought it was clogged up carb cuz its been sitting for a year the guy said. took carb off and not clogged at all. I do know the gas is super super stale though you can smell it. Anyway long story, i lost the a jet so cant put it back together yet lol, but i have another one coming in mail. Could it only be the stale gas?? I hope so. Or should i try the spark plug too?? let me know thanks.

bike has pretty low hrs. seems to me has to be something simple.

Share this post


Link to post
Share on other sites

plugged PJ

destroyed diaphram

plugged MJ

plugged LJ (replace with 55)

 

i would replace those 4 things and know it was all good.

but would use forced air to make sure all passages were clear

Share this post


Link to post
Share on other sites

See if the accelerator pump control in the carb is put together correctly and operating right. My 05 WR250 was doing that if I could get it to start at all. Turns out it was running super rich and that's why. That's all the advice I can offer though. Hope you get it going good!

Share this post


Link to post
Share on other sites

I would recommend to change new jets. I cleaned my carb and jetting many times and they would still get clogged... all the problems got solved with brand new jetts. Now starts and revs like a champ. Also noticed that it's really picky on airfilter quality and oil amount.

Share this post


Link to post
Share on other sites

how can it be the jets? I took them all out and there perfect. no blocking or nothing. can see light straight through them.

Share this post


Link to post
Share on other sites

ok thanks I'll try the pump. and how can it be the jets? I took them all out and there perfect. no blocking or nothing. can see light straight through them. very clean.

Share this post


Link to post
Share on other sites

picked up an 08 250f that's been sitting for a year, has minimal hrs. put fresh gas in it and cleaned the carb and jets but they weren't even dirty or clogged. starts up idles only on choke. can give it gas no problem. push choke off and it will die or I can keep it going reving at high rpms. in between revs you can tell it wants to die. it does not pop or anything. any help thanks?

Share this post


Link to post
Share on other sites

no but I doubt that's it. tuning issue. put fresh gas and put carb back together and it only runs on choke. can keep it going at high rpms with choke off but that's it. even then it runs kinda crappy

Share this post


Link to post
Share on other sites

no but I doubt that's it. tuning issue. put fresh gas and put carb back together and it only runs on choke. can keep it going at high rpms with choke off but that's it. even then it runs kinda crappy

did someone pull the slide out and install the plate upside down? Very easy to get wrong as the wrong way will look correct to the uninformed.

An upside down plate will give similar results to what you've posted as symptoms.

Look down the carb throat from the engine side. With the slide closed, you should see a small hole at the bottom of the slide. No hole visible then that is the problem.

Share this post


Link to post
Share on other sites

buy a BRAND new pilot jet.

Ensure the fuel screw is complete.

Did you have the slide out?

ok I will. and ensure the fuel screw is complete? and no I didn't remove the slide.

Share this post


Link to post
Share on other sites

ok I'll check the slide out. and as far as the fuel screw I don't know where that is and how to check the o ring? should I get an adjustable one from Motorsport?

Share this post


Link to post
Share on other sites

Remoive the fuel screw. With it should be a spring then a washer and then a tiny oring. Blow cmopressed air thhrough and confirm it passes freely.Reinstall the screw, tightten gently and stop when lightly bottomed. Then back it out 1.75 turns. Fine adjust once the bike is running. Adjust for a perfect smooth idle when hot.

Share this post


Link to post
Share on other sites

The fuel screw is at the front center of the float bowl it goes up and into the carb body. Should be a screw,spring, small metal washer, and a small o-ring, An adjustable screw is a good idea.

 

Share this post


Link to post
Share on other sites

Remoive the fuel screw. With it should be a spring then a washer and then a tiny oring. Blow cmopressed air thhrough and confirm it passes freely.Reinstall the screw, tightten gently and stop when lightly bottomed. Then back it out 1.75 turns. Fine adjust once the bike is running. Adjust for a perfect smooth idle when hot.

alright man thanks I'll give that shot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×