Jump to content
Sign in to follow this  

Picking up a 690 Enduro R this morning...

Recommended Posts

Just wanted to say hello. I'm from the DRZ400 side of TT and am taking the KTM plunge today. I'm sure I'll be asking stupid questions soon... lol

It's a 2010 with 1700 miles. I'll post a pic when I get it home. Now I just need a buyer for my DRZ!

  • Like 1

Share this post


Link to post
Share on other sites

Well, got the bike and 30 miles into my 50 mile ride home... dead! Bike started acting like is was running out of gas (it wasn't) then died and wouldn't restart. After letting it sit for awhile, it would re-start, run for awhile then die. The dealer came and picked it up. What a day. I'm thinking fuel or heat related (very hot today). The bike could have sat around for a long time.. who knows.

 

Here's the picture I promised.. lol

 

20130830_151848_zps2480cace.jpg

Share this post


Link to post
Share on other sites

My buddies 690 did the same thing, it stopped after he desmogged it. Was causing the tank to vapor lock.

Share this post


Link to post
Share on other sites

Thanks for the info! It's back in the dealers hands so I know they won't de-smog it, they can't. But I can when I get it back.

Share this post


Link to post
Share on other sites

Probably a clogged injector or fuel filter. I'd replace the filter and blow out the injector or have it cleaned. There seemed to be a spate of issues people have mentioned, though I haven't had any issues on my 2012 with 7500 miles on it so far. If the bike sat for a long time I'd blame bad gas.

 

Other things to check are the coil wires/ignition wires which can vibrate loose if not secured well. 

Share this post


Link to post
Share on other sites

Dealer just called, the bike is ready. I'll know more tomorrow, but they are saying some vacum hoses were disconnected and they "fine tuned the mapping"... lol. Not sure what all was really done but the service manager will talk to me when I pick it up tomorrow. I'm excited, it's like buying it all over again... lol. Hopefully this time I make it home!

Share this post


Link to post
Share on other sites

Got her back. Bike runs great. Here's what the dealer says... Found/repaired vacuum leak. Rerouted gas cap hose due to possible crimping while riding. Tested the fuel pump, including a pressure test both at idle and while riding. Checked the sensors. Had to sync the APAD. Cleared error codes and did 15 minute system reinitialization.

 

I have a question.. what's this? Ca smog related??

 

20130905_141415_zps80037d15.jpg

Share this post


Link to post
Share on other sites

hope u are happy with your 690 r.......best dual sport out their at the moment.......

 

Yes, I'm having fun with it. I'm picking up a set of supermoto wheels for it on Saturday. Two bikes in one!!!

Share this post


Link to post
Share on other sites

My 17's are ready! Going to pick them up in the morning. I'm pretty excited. These are Talon hubs with Excel rims and Bridgestone tires. It's a crappy cell phone pic.

 

IMG9511481_zps264c5bb0.jpg

Share this post


Link to post
Share on other sites

Nice bike. Have fun with it. :ride:

Share this post


Link to post
Share on other sites

Looks familiar. I absolutely love my 2013 as well. Now you've got me thinking of buying a set of wheels as well. Two bikes in one can't beat it.

Edited by ktm4jim

Share this post


Link to post
Share on other sites

Looks familiar. I absolutely love my 2013 as well. Now you've got me thinking of buying a set of wheels as well. Two bikes in one can't beat it.

 

This will push you over the edge... lol. I really am enjoying this bike!

 

DSC_6646_tonemapped_zps5dff6b3e.jpg

  • Like 1

Share this post


Link to post
Share on other sites

im in Thailand and I know they sell the 690 r. here.......in Bangkok. but due to import fees the bike is like 20000 dollars us.........what a joke........ktm needs to get their act together in asia

Share this post


Link to post
Share on other sites

Got her back. Bike runs great. Here's what the dealer says... Found/repaired vacuum leak. Rerouted gas cap hose due to possible crimping while riding. Tested the fuel pump, including a pressure test both at idle and while riding. Checked the sensors. Had to sync the APAD. Cleared error codes and did 15 minute system reinitialization.

 

I have a question.. what's this? Ca smog related??

 

 

 

That thingy opens a vaccum port to direct fuel vapors from the gas tank to the charcoal filter

 

Edited by DeepSeaOne

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×