2006 KX250F Wont start, Please help

Hello, My KX250F will not start. I have spark, Fuel, Timing is good, Every third or fourth kick it will backfire but it wont start.    I just put new stock cams in it, new exhaust valves, new stator and coil. Could this just be a matter of improper shims?

Have you checked the valves clearances ?

Are you sure the cam timing is correct as backfiring like that can be incorrect timing .

Valve clearance I would say. Had the same issue recently.

Have you checked the valves clearances ?

Are you sure the cam timing is correct as backfiring like that can be incorrect timing .

Im pretty sure because the cams are new and they are stock. at TDC on the flywheel, the cam markings are lined up with the head. And also the cam lobes seem to be in the proper places. I have had problems all summer, because i bought the bike and the exhaust cam was spun, but it had been welded so then  it destroyed 2 exhaust valves, and valve buckets. I put everything back together with new cams and i figure i have the clearances correct and it still wont start, just backfiring. ( when it backfires i get a huge flame out the exhaust)

Valve clearance I would say. Had the same issue recently.

So you figure my valves are not opening enough, or opening too much? 

I don't think you understand what valve clearances are, I would suggest you get a owner's manual and read up about it, or have a look on youtube to learn how to check them.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now