Jump to content
Sign in to follow this  

Problems with a 13 kx250f

Recommended Posts

The inlet valves pulled in my 13 with only 23hrs, pretty positive it took in some dust. Was running when I finished riding went to start the next weekend and wouldn't start. I had the shop put in SS valves and re shim them, I all so put a set of rings in as well.

  Now the bike starts first kick idles for a minute or so then dies, try and give it throttle and it just dies, never having had F.I bike before don't know where to start any suggestions?

Share this post


Link to post
Share on other sites

The inlet valves pulled in my 13 with only 23hrs, pretty positive it took in some dust. Was running when I finished riding went to start the next weekend and wouldn't start. I had the shop put in SS valves and re shim them, I all so put a set of rings in as well.

  Now the bike starts first kick idles for a minute or so then dies, try and give it throttle and it just dies, never having had F.I bike before don't know where to start any suggestions?

I'd take it straight back to the shop, let them worry about swapping out sensors, fuel pumps and so on, just have a quick look that all electrical connectors are connected.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×