Jump to content
Sign in to follow this  

Bike is not running properly

Recommended Posts

Hi, i have a 2007 crf 150r big wheel that is not running right. When the rpm is low andIi go to give it gas it sputters then as it gets into the higher rpms it runs fine. when inspecting the bike I checked the oil and found that it was very high. This is not normal because when I started running it was normal. I do not know if these problems are related or not. The sputtering I thought could be the valves but I do not know. Any help or tips is appreciated. 

Share this post


Link to post
Share on other sites

The engine oil is high and the hose is not kinked

 

 

OK. Is the trans side low? If the oil isn't passing the seal between the engine reservoir and the trans reservoir, then is it possible (it doesn't seem all that plausible) that you have a stuck float passing enough fuel past the rings to dilute (and increase the volume of) the engine oil?

 

Edit: a stuck float would spill fuel out the overflow tube. A bent float and high float level in the carb is what I meant. Sometimes happens after a big crash.

Edited by Old Plonker

Share this post


Link to post
Share on other sites

OK. Is the trans side low? If the oil isn't passing the seal between the engine reservoir and the trans reservoir, then is it possible (it doesn't seem all that plausible) that you have a stuck float passing enough fuel past the rings to dilute (and increase the volume of) the engine oil?

Edit: a stuck float would spill fuel out the overflow tube. A bent float and high float level in the carb is what I meant. Sometimes happens after a big crash.

Would a bent float like that explain the running poorly in low rpms?

Share this post


Link to post
Share on other sites

It makes the pilot circuit especially rich, without affecting the main near as much.

Does the oil seem thinned out and smell like gas?

Share this post


Link to post
Share on other sites

It makes the pilot circuit especially rich, without affecting the main near as much.

Does the oil seem thinned out and smell like gas?

The oil is thinned out and does smell like gas so I am almost certain gas is getting in with the oil. I am going to take the carb apart and look at the float to see if there is any damage to it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×