Jump to content
Sign in to follow this  

Speedometer is working but mileage counter is not

Recommended Posts

:banghead:  This is on my Real S like I said the MPH works just fine but the mileage/trip meter is not counting stays at 0. :cry:

Share this post


Link to post
Share on other sites

so in a few years you will have a low mile drz LOL

 

open it up and poke around for a messed up plastic part or get a vapor dash ?

  • Like 1

Share this post


Link to post
Share on other sites

Are you on the wrong screen/setting?

I've done that before.

I set odometer to subtraction from TRIP A, and I wondered how I only did XX miles in one day.

Share this post


Link to post
Share on other sites

OH...crap...just looked again and my total mileage is at 0 too... I was a 22,050 but  reads 0 now WTF?

Share this post


Link to post
Share on other sites

OH...crap...just looked again and my total mileage is at 0 too... I was a 22,050 but  reads 0 now &%$#@!?

 

 

Now you have a really super low mile bike....lol....often repair can be expensive,maybe hunt around for a used speedo unit or go for a Vapor....

Lotsa guys probably have them lying around in there garage after fitting the vapor unit...

I know I have a spare speedo off my SM, but that's in KMS...

 

It's going to be annoying not having some sort of mileage recording for a multiple of reasons..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×