No idle on 04 YZ250f

We're trying to figure out why the bike won't idle and every time you let off the throttle all the way the bike just shuts of. The bike also tends to backfire, not all the time but we were thinking that maybe that has something to do with it. perhabs messing with the air/ fuel mixture? The bike also used to have a Dr.D exhaust on it and was jetted for that but it was broken in a crash, so maybe the jetting has something to do with it because it wasn't rejected after the stock exhaust was put back on??

 

If anyone has any ideas as to what it might be please help.

 

Also, is the black knob on the left side of the carb the air/fuel mixture or is it the idle screw?

We're trying to figure out why the bike won't idle and every time you let off the throttle all the way the bike just shuts of. The bike also tends to backfire, not all the time but we were thinking that maybe that has something to do with it. perhabs messing with the air/ fuel mixture? The bike also used to have a Dr.D exhaust on it and was jetted for that but it was broken in a crash, so maybe the jetting has something to do with it because it wasn't rejected after the stock exhaust was put back on??

 

If anyone has any ideas as to what it might be please help.

 

Also, is the black knob on the left side of the carb the air/fuel mixture or is it the idle screw?

replace your pilot jet with a new one

learn how to adjust your fuel screw on the bottom of the carb ('pilot setting' post at the top of the forum)

that is the choke

It sounds like a jetting issue possible air fuel. But the knob on the side is your idle the air fuel is a tiny screw you can access from the bottom of the carb. Also how does it run with the choke on?

@AHill11

 

The bike used to start a lot easier with the choke on but now it starts fine without it. it starts second kick and runs fine with the exception of the slight backfire. it just doesn't want to idle or stay on with out any throttle.

@AHill11

 

The bike used to start a lot easier with the choke on but now it starts fine without it. it starts second kick and runs fine with the exception of the slight backfire. it just doesn't want to idle or stay on with out any throttle.

Right. You need to put in a new pilot jet, yours is corroded.

I had the same problem with myn , I didn't think anything of it , one month later it had its rod hanging out the side of the barrel.

 

Coincidence? hahaha

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now