Jump to content
Sign in to follow this  

06 kx450f, where do i begin?

Recommended Posts

hey guys, not really sure where to begin here... bought the bike used in spring of 09. the guy flipped it over backwards & broke the tailpipe, handlebars & rear fender. i replaced everything & installed an FMF factory 4.1 slip on. it has always had a bit of a decel. pop/backfire but i recently installed a powerbomb header & it seems to have gotten worse. the bike ran fine otherwise. once i installed the powerbomb header i was having problems with my boot melting to the pipe, so i wrapped it with that fiberglass exhaust wrap from head bolts to the midpipe/header joint. i also installed all new plastics/ seat/ & fuel tank. after this my bike has not ran propeerly. at first the bike would run out of fuel & not start for a while(or so it seemed) i cleanded out the fuel filter a few times & checked all the hoses. PROBLEM, with the added depth of the tank the hose was kinking where it left to meet the petcock, a quick turn of the fuel valve & it unkinked & seems t o be getting gas now. while it was apart i ckecked the gascap too, thinking it could be clogged. the bike starts fine, runs good but still has that popping & after about 5 minutes of riding today it began to die {as if starving} (on idle) in the apex of a turn with the clutch in. a quick dump of the clutch & it was running again but the problem persists. i just cleaned air filter(foam filter products unavailable do to location, used mineral spirits & chainsaw bar oil( , changed oil & filter, new antifreeze aswell. the guy who owned it before me must have played with the carb, i went as far as returning the fuel/air screw to stock position & it idled extremely high, backfired on idle! & spewed antifreeze from the vent ( this has been dripping now for a couple short rides). i returned it to where he had it (a whopping 3 3/4 turns out!!) & it idles normal again, but still has a bit of a pop. i dont know if any of this is relevant but i dont want to do any unnesscary dissambly/ "tinkering' if i can avoid it. also the bike seems to be leaking a SMALL amount of oil around the spark plug hole, where the cam cover meets. im ordering a new rad cap, gonna clean & return the carb to factory spec,  put a new petcock & fuel lines on just for piece of mind, & check for exhaust leaks. i assume i should check the intake boots aswell. any advice is REALLY aprreciated. where should i look first, what the best way to check for leaks? should i send the motor out if i cant fix it or save for a crate motor over the snowy season? i lost guys someone help me, i loved my baby girl till she started acting up... now i dont know what to do with her...

EDIT: im not sure if the rad cap is shot or if its over heating that bad but i cannot ride it now with losing that precious green liquid all over

Edited by KxFlinFl0n

Share this post


Link to post
Share on other sites

hey guys, not really sure where to begin here... bought the bike used in spring of 09. the guy flipped it over backwards & broke the tailpipe, handlebars & rear fender. i replaced everything & installed an FMF factory 4.1 slip on. it has always had a bit of a decel. pop/backfire but i recently installed a powerbomb header & it seems to have gotten worse. the bike ran fine otherwise. once i installed the powerbomb header i was having problems with my boot melting to the pipe, so i wrapped it with that fiberglass exhaust wrap from head bolts to the midpipe/header joint. i also installed all new plastics/ seat/ & fuel tank. after this my bike has not ran propeerly. at first the bike would run out of fuel & not start for a while(or so it seemed) i cleanded out the fuel filter a few times & checked all the hoses. PROBLEM, with the added depth of the tank the hose was kinking where it left to meet the petcock, a quick turn of the fuel valve & it unkinked & seems t o be getting gas now. while it was apart i ckecked the gascap too, thinking it could be clogged. the bike starts fine, runs good but still has that popping & after about 5 minutes of riding today it began to die {as if starving} (on idle) in the apex of a turn with the clutch in. a quick dump of the clutch & it was running again but the problem persists. i just cleaned air filter(foam filter products unavailable do to location, used mineral spirits & chainsaw bar oil( , changed oil & filter, new antifreeze aswell. the guy who owned it before me must have played with the carb, i went as far as returning the fuel/air screw to stock position & it idled extremely high, backfired on idle! & spewed antifreeze from the vent ( this has been dripping now for a couple short rides). i returned it to where he had it (a whopping 3 3/4 turns out!!) & it idles normal again, but still has a bit of a pop. i dont know if any of this is relevant but i dont want to do any unnesscary dissambly/ "tinkering' if i can avoid it. also the bike seems to be leaking a SMALL amount of oil around the spark plug hole, where the cam cover meets. im ordering a new rad cap, gonna clean & return the carb to factory spec,  put a new petcock & fuel lines on just for piece of mind, & check for exhaust leaks. i assume i should check the intake boots aswell. any advice is REALLY aprreciated. where should i look first, what the best way to check for leaks? should i send the motor out if i cant fix it or save for a crate motor over the snowy season? i lost guys someone help me, i loved my baby girl till she started acting up... now i dont know what to do with her...

EDIT: im not sure if the rad cap is shot or if its over heating that bad but i cannot ride it now with losing that precious green liquid all over

I would check the valve's and shims and make certain that they have proper clearance and are sealing the combustion chamber before doing anything else.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

  • Similar Content

    • By tanner_shany24
      Hey guys, I have a 2012 KX450f and it is giving me major issues. I will give you a run down of the history of it. I bought this bike a few months ago and have only ridden it really once, yes once! When I bought it everything seemed to check out, it ran fine, started fine, sounded fine, so I bought it. Took it out to ride and the first hill I hit it got really hot and overheated like a SOB and spewed coolant everywhere. I thought to my self maybe it was because we were riding trails slow before so maybe when I actually got on it it got too hot. After that though, it began to overheat every 3 minutes no  matter what, I would ride it for 3 minutes, and have to stop to let it cool down because I was scared I was going to melt the top end. Got home and started inspecting, found out that oil and coolant was mixing both where the oil is supposed to be and where the coolant is supposed to be. After some research I found that the 2012 450 had head gasket issues. Assuming that was the issue, I took the head off and got it resurfaced (it was actually decently warped) and put new gaskets in everything top end related. Piston and cylinder looked brand new by the way. So I put it back together, started it up, and it instantly started spewing coolant and oil mixed out of the crank case breather hose. Like literally as soon as i started it and it would make a puddle on the ground in 10-15 seconds. I'm at a loss here, brand new coolant and brand new oil, brand new head gasket and resurfaced head, and it instantly started doing the same thing again? What could it be? Is it worth my time or do I part the bike out? I have put way too much time into this bike to want to tear back into it again unless it is something cheap to fix, if not I am going to post it on craigslist and let someone else deal with it. Overall this whole experience makes me want to go back to a 250T! XD
    • By Sam Mclean
      Hi new to this site.
      Ive just bought a cheap kx450f with what i thought would be a minor issue.
      I was told it was only running with the choke on and i thought easy fix, just a blocked jet. So i pulled it apart as must of the person before me and i find a broken soround thing that the plastic case sits on around the pilot jet. So i appoxy that back on unblock the jets and clean it all out, put it back together and now i try starting it for the first time and see the fuel dripping as it was when i bought it. When i look closer i see it is seeping from what looks like a crack in the float bowl. Ahhh
      So my problem is. Looking for a cheap carby might solve all my problems or just a float bowl at worse case. Now i can find many kx450f being wrecked nearby so im wondering are most 450 carbys the same? Will one of a yz450f work? 
      Can someone please help
    • By Sam Mclean
      Hi new to this site.
      Ive just bought a cheap kx450f with what i thought would be a minor issue.
      I was told it was only running with the choke on and i thought easy fix, just a blocked jet. So i pulled it apart as must of the person before me and i find a broken soround thing that the plastic case sits on around the pilot jet. So i appoxy that back on unblock the jets and clean it all out, put it back together and now i try starting it for the first time and see the fuel dripping as it was when i bought it. When i look closer i see it is seeping from what looks like a crack in the float bowl. Ahhh
      So my problem is. Looking for a cheap carby might solve all my problems or just a float bowl at worse case. Now i can find many kx450f being wrecked nearby so im wondering are most 450 carbys the same? Will one of a yz450f work? 
      Can someone please help
    • By BadcaseofTB
      I missed tracking where this little top hat came out of in my 2011 kx450f. Was thinking clutch or right side engine cover. Any help would be appreciated I can’t seem to find it in the manual.

×