Jump to content
Sign in to follow this  

rekluse hi-rpm slipping 500exc

Recommended Posts

Just got my Rekluse core exp installed today and am have some slipping in the higher rpms. I set the bellevelle spring to the 3 mark and still get the slippage. Rekluse recommends the heavy duty Bellevelle spring so i'll try that but wondering if anyone else had the issue. I am currently just running the recommended Motorex oil. Freeplay seems good at least 3mm of freeplay.

 

Bill

Share this post


Link to post
Share on other sites

Something isn't right. I had trouble with the EXP in the 500 slipping at low RPM but replaced it with the Core. I have the stock spring set at the #2 position and it doesn't slip at all. There is no reason that the Rekluse would slip when your stock setup didn't. I also don't run the gap as wide as they recommend either. I suspect that ball ramp wear would be accelerated with a stiffer Belleville spring too.

 

I still think Rekluse needs to make the Pro available for the 500. It seems it's literally the only bike that the EXP style clutches aren't working as well and most of the complaints have been the guys riding technical trails, not racing or guys riding more open stuff.

Share this post


Link to post
Share on other sites

Something isn't right. I had trouble with the EXP in the 500 slipping at low RPM but replaced it with the Core. I have the stock spring set at the #2 position and it doesn't slip at all. There is no reason that the Rekluse would slip when your stock setup didn't. I also don't run the gap as wide as they recommend either. I suspect that ball ramp wear would be accelerated with a stiffer Belleville spring too.

 

I still think Rekluse needs to make the Pro available for the 500. It seems it's literally the only bike that the EXP style clutches aren't working as well and most of the complaints have been the guys riding technical trails, not racing or guys riding more open stuff.

I've tried it on all the marks and pulled it apart a couple times to verify that it's stacked correctly. I'm going to measure the disks and make sure they are in spec. I've played with the freeplay and it is still slipping on the street. only in the mid to high revs though. It is weird and pretty frustrating.

Share this post


Link to post
Share on other sites

It might slip on the street with good traction tires, I don't play too much on the street with mine since I have it geared down. I'd put the 280 Belleville in it, dump the Motorex and try the standard Rotella 15-40. I've had some trouble with slipping using synthetic oil.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×