Jump to content
Sign in to follow this  

2007 CRF80F cutting out

Recommended Posts

Ok, didn't want to use my TT card on this simple problem but it is getting annoying and I'm tired of taking it apart.

It has sat for about a year (wife's bike) and I decided to get it running to sell. I replaced the gas Cleaned the carb and jets. Replaced the plug. Adjusted the valves checked the air filter.

Removed the petcock and the filter was deteriorated so I just removed it for now and cleaned out the tank.

It ran fine last time we had it out but now it cuts out when running fast. I wouldn't think it's electrical but dang, aint going to rule it out.

I have repeated the carb cleaning process several times thinking debris may have gotten to the main jet but it is clean.

Any ideas?

Share this post


Link to post
Share on other sites

maby fuel line partially plugged up??? causing enough flow for low speed but draining the carb too fast at high speeds. or maby the fuel tank vent line, no air in no fuel out kinda thing. just ideas maby they'll help maby not   :excuseme:

Share this post


Link to post
Share on other sites

maby fuel line partially plugged up??? causing enough flow for low speed but draining the carb too fast at high speeds. or maby the fuel tank vent line, no air in no fuel out kinda thing. just ideas maby they'll help maby not   :excuseme:

Thanks,

I didn't think to check vent hose. I will also double check flow from the petcock.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×