Jump to content
Sign in to follow this  

Pro Circuit Water Pump impeller installation

Recommended Posts

I have just shelled out to buy myself a pro circuit water pump but have a question with regards to the impeller installation.....

The impeller came with a cable around it which also held a small washer into a groove on the backside of it, but I also got a washer in the parts bag for it. Do I install it with both washers? Or just use one? The PC instructions say to install it with the washer from the parts bag but there is no mention of the washer already held on by the cable tie.....

One other question when installed should the impeller spin freely or does it only spin with the engine running????

Any advice would be greatly appreciated cheers....

Share this post


Link to post
Share on other sites

I have just shelled out to buy myself a pro circuit water pump but have a question with regards to the impeller installation.....

The impeller came with a cable around it which also held a small washer into a groove on the backside of it, but I also got a washer in the parts bag for it. Do I install it with both washers? Or just use one? The PC instructions say to install it with the washer from the parts bag but there is no mention of the washer already held on by the cable tie.....

One other question when installed should the impeller spin freely or does it only spin with the engine running????

Any advice would be greatly appreciated cheers....

Share this post


Link to post
Share on other sites

I installed mine with just the one washer that was on the cable tie and kept the one in the bag just in case. I've been running it like this for 3-4 months now with no issues. Once you tighten down the impeller it should not be able to turn freely/easy

  • Like 1

Share this post


Link to post
Share on other sites

Sorry guys 2012 kx250f,

I originally put both washers on but then changed it back to one and kept the in the bag as a spare aswell.I will be taking the bike out for its first run tomorrow hopefully everything goes well. Thanks for taking the time to reply

Share this post


Link to post
Share on other sites

Another one?

 

What make? What model? What freaking year?

 

I would just like to point out the fact that these water pumps have been the same since the 250f came out. Also this is the KX250f forum.

Share this post


Link to post
Share on other sites

I would just like to point out the fact that these water pumps have been the same since the 250f came out. Also this is the KX250f forum.

 

Tactfully done.  I couldn't answer definitively.  I know there is a washer behind the impeller.  I don't know where the other washer should go.  One would think it would be in the instructions . . . 

 

But the make/model seemed obvious and the year . . . well, that would have been irrelevant.

Share this post


Link to post
Share on other sites

FYI, this thread was moved from the enginerring/tech section, where guessing the make/model/year is difficult. It was moved here after searching the OP's other posts and determining he has a KX2509F. The OP also made several identical threads, which have been merged and duplicate posts removed (except the opeing posts, there were retained to illustrate duplicity).

Share this post


Link to post
Share on other sites

FYI, this thread was moved from the enginerring/tech section, where guessing the make/model/year is difficult. It was moved here after searching the OP's other posts and determining he has a KX2509F. The OP also made several identical threads, which have been merged and duplicate posts removed (except the opeing posts, there were retained to illustrate duplicity).

 

Figured as much.  Good to have it explained here, though.  Now it is crystal clear.  Thanks Will.

Share this post


Link to post
Share on other sites

FYI, this thread was moved from the enginerring/tech section, where guessing the make/model/year is difficult. It was moved here after searching the OP's other posts and determining he has a KX2509F. The OP also made several identical threads, which have been merged and duplicate posts removed (except the opeing posts, there were retained to illustrate duplicity).

Hmm. Naturally I would look like an ass. Any chance of adding a "Moved from" tag on these threads?

Share this post


Link to post
Share on other sites

Hmm. Naturally I would look like an ass. Any chance of adding a "Moved from" tag on these threads?

 

LOL Josh.  You crack me up!  :thumbsup:

Share this post


Link to post
Share on other sites

Wow....sorry for any confusion forgetting to put my bike model in, I did on my first reply to the post to clarify. The OP did not make several posts the same but just 2 as I couldn't work out which forum was the best to post my question.

My question has now been answered by the original replier. So thanks everyone for your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×