650L CDI Unit Wiring Example?

First off, thanks for any advice I get. You guys are great!

 

My pig runs, but showed problems that led me to the CDI/Pulse Generator. The CDI unit is a mess. There's no original plastic connector on the wire end, just some random female connectors.

There are 6 wires connected individually on the CDI. I noted the 'original' position of the wires on paper, just in case. Then I find another wire that had been trimmed up and tucked under the wire wrap. So I'm not sure what someone did to this thing. I've seen diagrams online, but haven't seen any clear photos of the wires going into the CDI unit.

 

Here's the wire colors from left-right. Black&white, green&white, yellow&red, blue&yellow, green, black&yellow, light blue.

The black and yellow wasn't hooked up. It was cut and tucked up under the wrap. 

 

Would someone be so kind as to post a good pic of where all the wires lead into the CDI? I would love to see what it is supposed to look like. 

IMAG00271.jpg

How about a pic of just the connectors and the wires going into them?

I have 7 bare wires, 6 holes to plug them into and only half a clue on what I'm doing. 

SHOW ME YOUR CDI WIRES!

please...

Sorry everyone,

You can all relax now. I think I found the problem. It appeared I had 7 wires going to my CDI. Turns out the blue wire in the pic was spliced into the yellow/black wire a little farther up. 

The leftover black/yellow wire hadn't been plucked out of the sheath making it look like there were 7 total. :|

A little investigating and I found the splice, a little tug and the leftover yellow/black wire slid out. 

So I have the original running order for the wires on paper and should make for easy New CDI install.

Please disregard this entire calamity.

Black/Yellow,,not hooked up,,Bizarre ,,That's supposed to go to the coil so I'm not sure how the thing actually even ran..The Blue you can kinda forget,,that's to do with I think the indicators or horn..Sorry I have no picture of a 650L CDI with wires coming out of it..I'm looking for one for you..

 

Snap in post timing,,makes no sense to me what the blues doing hooked up to the CDI..Ah I see ,,So someones hooked a hunk of blue wire to the Black/Yellow and that goes to where the B/Y is supposed to on the CDI??/

Edited by Horri

Posted this a few times...

 

 

100_4409.jpg

 

 

 

100_4403.jpg

 

 

 

 

B

Edited by brianhare

I've never seen them before..I've saved them both to my files in the CDI department...You know what'd be really nice Brian..A picture of the actual CDI sitting with the pins at the top with the plugs inserted into the correct place and the wires spread nicely in a fan type arrangement so we can see it beautifully represented.. :rolleyes:

 

Their can be no confusion with a picture like that..One picture I do have of a 650L CDI layout has a green/red wire in it,,there is no green/red that goes to a 650L CDI according to my wiring diagrams..Confusion.. :crazy:,,,Cripes these colours are hard to read from pictures..some yellow stripes look white to me..

 

I know you love pictures and so do I,,specially for my files.. :thumbsup:

Edited by Horri

"So someones hooked a hunk of blue wire to the Black/Yellow and that goes to where the B/Y is supposed to on the CDI??"

 

Yeah, Horri, someone spliced it in further up and left the cut piece where it was, causing mass hysteria...

 

"Their can be no confusion with a picture like that.."

 

This is true. I'm looking at my "original" wiring diagram on paper and I'm not sure if it was even wired properly. 

We must summon the powers of Brianhare!

mmm;;He's a bit slack..I've done what I think are the correct positions for the 650L in a diagram..Don't know for sure if they are right till he turns up..Don't rely on them till we can get confirmation..I'll pull it and edit it if they are wrong..Done one for the 600s as well should we get the same question with them..

 

 

 

 

7ous.jpg

Uploaded with ImageShack.us

Edited by Horri

Come on guys.......look at the pics,,you can see where the locking tabs are located on the male connectors,,all you gotta do is grab a CDI and see where they be located,,that`s why i took the pics the way i did.......so people could see the locking spot on the connectors for  proper orrientation...

 

And Reg..........if you can`t figure it out with those pics then maybe you should back away from the bike and get someone else to look when you need these pics :devil:

 

Can`t make everything too easy for people,OTHERWISE THEY WON`T LEARN NOTHIN....

 

 

:moon:

 

 

 

 

:p

 

 

:lol:

 

 

B

Edited by brianhare

SEE BELOW

 

B

Edited by brianhare

So where I have BLu/Y is supposed to be Blu/W,,a wiring diagram actually uses L as Blue..I tried to make it easy by using Blu..So what is incorrect there..I need confirmation so I can redo the diagram..

Edited by Horri

Thanks guys! This will make it easy to properly hook up my CDI when it arrives soon. 

Just need to get some small female connectors from the shack. The original female connector for the wires would be nice though.

 

"So where I have BLu/Y is supposed to be Blu/W"

 

Is it? Mine looks to be a yellow strip on that blue... could be age.

Edited by motoburn

Yep...this is where the confusion comes in..the 1993 650L diagram I have uses L/Y..meaning Blue/Yellow..there's no blue/white according to it..

 

So what is the correct answer??? :banghead:..How do you mean there's no Red stripped wires..I see one in your picture ???Red/yellow..??,,@#$% is going on here..I'm supposed to be a bit colour blind but this is getting ridiculous..Come on guys :rant: I need to edit my diagram and update my files.

 

 

5z29.jpg

Uploaded with ImageShack.us

Edited by Horri

Right,,Seeing as I could get no answer on Blue/White or Blue/Yellow in my posted picture I've gone with either way.. :moon:

So where I have BLu/Y is supposed to be Blu/W,,a wiring diagram actually uses L as Blue..I tried to make it easy by using Blu..So what is incorrect there..I need confirmation so I can redo the diagram..

 

SEE BELOW

 

 

:devil:

 

B

Edited by brianhare

Thanks guys! This will make it easy to properly hook up my CDI when it arrives soon. 

Just need to get some small female connectors from the shack. The original female connector for the wires would be nice though.

 

"So where I have BLu/Y is supposed to be Blu/W"

 

Is it? Mine looks to be a yellow strip on that blue... could be age.

 

AGE................it`s white..

 

Peel the black tape back alittle where it`s not weathered,,,,,,white almost always turns URINE colored...

 

:lol:

 

B

ALLRIGHTY THEN...........i`m about to lose it................

 

My spare wiring harness has different colors than my 2001 XR650L...........

 

SOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO

 

I went out,took pics.........made this up for you...it`s as good as it gets ..with me...

 

Reg was right........mostly.........the bike wiring looks like this,,Reg,,you better appreciate it too.. :devil:

 

I edited out y previous posts,,,due to te 2 wiring harnesses giving incorrect colors..

 

 

 

DSC_2914_zps70a28723.jpg

AGE................it`s white..

 

Peel the black tape back alittle where it`s not weathered,,,,,,white almost always turns URINE colored...

 

:lol:

 

B

That doesn't explain the wiring diagram..I see no Blue/White in it..Let it ride for now but until someone produces another wiring diagram showing Blue/White I fail to be convinced.. :rant:

 

Oh my God.. :foul: The great minds think alike.. I'm not re-editing my diagram again..I've just finished updating all my files on all pc's,, USB sticks and phones with it..We'll call it a draw.. :lol:

 

I'll now add your new picture to them all.. :banghead:,,My next complaint is it's not upright.. :moon:..It'll do though.. :rolleyes:

Edited by Horri

Thanks.........just send money,this cost me 1 hour of beer drinkin time,,that`s worth about,ummmmmmmmm 100 bucks..

 

:jawdrop:

 

 

B

Thanks.........just send money,this cost me 1 hour of beer drinkin time,,that`s worth about,ummmmmmmmm 100 bucks..

 

:jawdrop:

 

 

B

Brian,,We just lost the Americas Cup to the blasted Yanks sailing there boat no doubt designed by us and crewed by our men...and you're concerned about drinking,,We just lost millions of dollars and a fair degree of pride..&@#$%s..Treacherous pirates all over the sailing world..Coutts..@#$%^&*...rrrrrr

Edited by Horri

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now