Jump to content
Sign in to follow this  

03 kx250 bogging and flooding problems

Recommended Posts

ok i have an 03 kx 250 its has new top end with weisco piston new crank and boyensen pro series carbon fiber reeds but its bogging past quarter throttle and acting like its flooding out at full throttle so i put the reed stoppers in it and it barely helped my pipe isnt dented up at all my power vavle seems to be working properly like going in and out ive taken the carb apart and there is nothing wrong with it this is really bothering me bc the first couple of days after rebuild it had the stock reeds and it ran great and didnt smoke at all until they broke and now it smokes and smells like i have a fuel leak but i dont i need some advice on wat i need to do im about tired of working on it but i dont want to give up yet could it be the power valve or the sensors on the carb or wat idk wat else to check

Share this post


Link to post
Share on other sites

Did it run fine before or after carb disassembly? If you smell fuel, then def flooding. If so...check float adjustment, and check the needle & seat for wear and/or debris.

Edited by bowhunter007
  • Like 1

Share this post


Link to post
Share on other sites

i took the carb apart to see if it was the problem but nothing was wrong with it does anyone think i should run a higher octane gas ive been using 93 octane pump gas with klots racing mixing oil

Share this post


Link to post
Share on other sites

What color is the spark plug? My guess is it's running rich.

 

And what do you mean tired of working on it? Working on the bike is the second most fun and the only to riding it.

Edited by moose_338

Share this post


Link to post
Share on other sites

What color is the spark plug? My guess is it's running rich.

And what do you mean tired of working on it? Working on the bike is the second most fun and the only to riding it.

I understand what he means, I love working on my bike, but it can get irritaring and tiring when you do a lot of work then encounter problems.

Share this post


Link to post
Share on other sites

ok i changed the plug and adjusted the floats and it semmed to help alot but i still cant give it full throttle without it bogging if i ease the throttle it runs great but when i try to crack it wide open it bogs and yes working on them is the second most fun but this bike is just idk i have never had one give me so many problems the whole thing is almost brand new bc i have replaced so many things on it if any is ever in tn or is in tn i want to sell or trade it

 

p.s

 thank you everyone for the advice and help you are giving im so used to honda this bike is confusing to but it has potential

Share this post


Link to post
Share on other sites

ok i changed the plug and adjusted the floats and it semmed to help alot but i still cant give it full throttle without it bogging if i ease the throttle it runs great but when i try to crack it wide open it bogs and yes working on them is the second most fun but this bike is just idk i have never had one give me so many problems the whole thing is almost brand new bc i have replaced so many things on it if any is ever in tn or is in tn i want to sell or trade it

p.s

thank you everyone for the advice and help you are giving im so used to honda this bike is confusing to but it has potential

Trust me, once you get it all worked out and rip it wide open in a nice stretch, you'll think its worth it.

So it does idle, and you can open the throttle slowly to get to wide open, but a fast snap back will result in bogging? Does it bog then get up there, or bog then stall?

Share this post


Link to post
Share on other sites

Look up how to jet a two stroke carburetor on Google and before you know it your bike will be running crisp and as clean as possible for under $10

Share this post


Link to post
Share on other sites

and yes it idles fine and bogs then stalls like its all the power it has

 

but question if the pipe is popping off the cylinder to much could that cause it like weak springs on the pipe or what bc when its in neutral i can crack it wide open and as soon as it starts to bog the pipe pops back from the cylinder and i know it susposed to to an extent but it looks like its going to far

Share this post


Link to post
Share on other sites

and yes it idles fine and bogs then stalls like its all the power it has

but question if the pipe is popping off the cylinder to much could that cause it like weak springs on the pipe or what bc when its in neutral i can crack it wide open and as soon as it starts to bog the pipe pops back from the cylinder and i know it susposed to to an extent but it looks like its going to far

What the...? The pipe shouldn't move AT ALL. Maybe 2 CM of play at most, and that's certinaly not in and out play. Check the 2 pipe mounts. Replace your springs.

Share this post


Link to post
Share on other sites

ok i will do that tomor but does any one know if i have to or should change the jetting since i have put carbon fiber reeds in it ik that changes some of the air flow but idk if it makes that big of a difference also ive noticed if i stay in when then power band kicks in if i dont shift within like maybe 5-15 secs after they do it bogs in every gear like that so i have to shift bf it picks up all the way then 4th is a lil slugish but 5th it just like drops way down its like i can go faster 1st-3rd than i can in 4th-5th like im lossing alot of power im just curious like ive said ive never had a dirtbike give me so many problems

 

p.s what is a good spark plug to use and were can i get one

Share this post


Link to post
Share on other sites

doe anyone think i should change my main jet bc ik when the needle jet is all the way up which is full throttle and in 4th-5th that the main jet is wat controls the jetting at those points so should i put a bigger main jet in it and does any one know if changing the reeds has anything to do with the jetting like ik that with the carbon fiber reeds its a faster response which i think means it lets a lil more air in at once so i have adjusted my floats so now it barely bogs 1st-3rd unless i give it full throttle ive changed my plug ive adjusted my fuel/air mixture and idle to were it idles great but still bogs at full throttle so yea if im confusing yall im sorry im confused my self im a lil add when it comes to this stuff so my mind is running 90 to nothing lol but yea if anyone knows if that should help i appreciate the help thank you

Share this post


Link to post
Share on other sites

does anyone know what size the stock jets are for this bike im not sure but it has a 160 main and a 52 pilot with a stock needle and my pug is black its a new plug only been ran 3-4 times maybe 10 min max each time does any one think if i put a smaller main in and a new plug if it would help or do i need a complete jet kit

Share this post


Link to post
Share on other sites

ok so i finaly figured out what my problem was my stator bolts came loose and fell out so i put new ones in and now it runs perfect but thank you all for your help i atleast learned some new things

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×