Im afraid to ask.

Yeah as the title states, im afraid to ask this because I think I already know the answer. My rear swing arm on my 2005 ttr 230 seems to be moving side to side just a very slight amount. Its about a millimeter of side to side travel at the axle for the rear tire. I have already tightened the swing arm bolt up a little bit but it still does it. Its it ok like this or do I need to replace something. :confused:

Not sure how much torque you have put on the nut to tighten it but I have always cranked mine down to Hulk specs and never had an issue, simply because I do not want my wheel or chain to come out of adjustment. First make sure all your spacers are correctly in place and get you a 14" crescent wrench and try to twist it off, you will stop before that nut strips. I'm 6 feet tall and a muscular 225 and I've never been able to strip one.

Edited by clint eastwood

Not sure how much torque you have put on the nut to tighten it but I have always cranked mine down to Hulk specs and never had an issue, simply because I do not want my wheel or chain to come out of adjustment. First make sure all your spacers are correctly in place and get you a 14" crescent wrench and try to twist it off, you will stop before that nut strips. I'm 6 feet tall and a muscular 225 and I've never been able to strip one.

Ok ill go check the torque on it later today but i asked my dad and he said it might be swing arm bushings/bearings.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now