Jump to content
Sign in to follow this  

Speedo inaccurate?

Recommended Posts

Can you guys with a GPS please verify what I'm thinking:  The DRZ-S speedo is reading fast, like maybe +5 mph at 55?  I live in the boonies with no mile markers or radar signs so I can only go by how traffic wants to pass me when I'm going the speed limit @ 55mph.

 

I had a TrailTech Vapor on my '05 E and you dial that in at setup.  This factory unit seems very optimistic. 

Share this post


Link to post
Share on other sites

Can you guys with a GPS please verify what I'm thinking: The DRZ-S speedo is reading fast, like maybe +5 mph at 55? I live in the boonies with no mile markers or radar signs so I can only go by how traffic wants to pass me when I'm going the speed limit @ 55mph.

I had a TrailTech Vapor on my '05 E and you dial that in at setup. This factory unit seems very optimistic.

no speedo or even rev counters are 100%

Share this post


Link to post
Share on other sites

This factory unit seems very optimistic. 

I would like to know how optimistic the DRZ speedo is also.

 

My 650 Burgman is 9.5 % optimistic, but pretty easy to figure the speed. 55 indicated is actual 50, 77 is 70 .

Share this post


Link to post
Share on other sites

Yeah, mine was off by a lot as well.  Funny thing though, the trip odo was dead nuts on, as long as I left the calibration scale at 100 percent.  When I took it apart a few weeks ago (after it died), I found that the speedo cable direct drives a pulse tachometer wheel with four nice large windows for the infrared LED to shine through to a discrete photo eye to count pulses.  Therefore, the only inaccuracy in the system (other than tire circumference differences) was the lousy clock.  If they had put a decent clock in there, it would have been as perfect as the trip odometer.

 

My DRZ OEM trip odometer typically agreed with my Garmin 62S within one or two tenths of a mile, at the end of long days on the trail OR on the road.,  Unbelievable, except that I saw it each day.

 

Tire choice also makes a big impact.

Share this post


Link to post
Share on other sites

Depending on tire choice, the OEM odometer is fairly accurate (and has to be, by federal law). The speed part however, is about 10% high. Which is fairly common. I think it has something to do with the 'bold new graphics'.

Share this post


Link to post
Share on other sites

I'm sure they intentionally make the speedometer high for liability reasons. Like William said.


Any motorcycle I have ridden indicates speed ~5-10% higher than actual.

  • Like 1

Share this post


Link to post
Share on other sites

I replaced my stock speedo a few years ago with a Vapor because it was so far off. By a whopping 30%. Once I did and got it all calibrated and checked it against my GPS unit it was very close. At least within a tenth of a mile. Way better than before. My reading for gas mileage were down to 33 mpg with the old one. Now I get between 45mpg highway and 55 offroad. Running at high speeds of 75mph on the highway sucks the gas down. Crossing the desert it does so much better cuz I usually cant or dont travel that fast.

Share this post


Link to post
Share on other sites

Thanks guys.  I figured it had to be off by about 5 at 55 mph by the way cars keep passing me.  If it was off only 2 or 3 they probably would try to be patient.  So 60 is the new 55.

 

 

keep in mind that every bike made reads high, same with cars, trucks, vans, etc

 

it's your 'wiggle' room for not getting a ticket. 

 

if you speed, and are caught speeding, the officer already knows:

 

1 your speedometer read higher than your speed

2 you disreguarded the higher speed reading, and continued

 

that's why they really don't care about excuses.

Share this post


Link to post
Share on other sites

My Nissan Frontier and my wifes Volvo are within 1%. I find most four wheel vehicles are accurate and most Euro bikes accurate. It seems Japanese bikes are almost all off by 10%. Probably a translation thing.......

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

  • Similar Content

    • By Bignerd0100100
      Hey all, 
      I'm looking at buying a 2004 Suzuki DRZ400EK or at least I think it's an EK according to Vin lookup websites, but it does not appear to have a kickstarter. I was told the bike was owned by a motorcycle dealer and that it has a current green sticker, and a California license plate but has not been registered for the streets since 2011. I want this as a dual sport but am not clear if the fact that it already has a plate means I am good to register it or if maybe they took away the ability to register it after it was plated, California loves to do that kind of stuff. Since the bike was owned by a dealer I would think they were up on the latest regulations in California, but who knows. Can anyone add any insight as to what I should look for on the bike itself like the carburetor, model numbers etc? Or do I just try my luck at the DMV?
    • By smokey9lives
      Hi,
      I have a 2003 DRZ (actually a KLX400) and the head tube bearings are shot.  I ordered a new set to install but I'm wondering if anyone has any recommendations on other parts I should replace while I have the front disassembled.  I was thinking about new rubber fork protectors, but are there other things that wear out on the DRZ front ends that you can only get to when disassambled?
      I also broke off a replacement key that I got for the steering lock.  I must have been made of cheap pot-metal.  Should I just remove the whole lock mechanism?
      Any tips or tricks for getting the old bearings out and the new ones in would be welcome!
      Thanks!
    • By antonyp
      Hey Guys,
      I recently bought a 2003 DRZ400S and thought it would be a good idea to check the valves clearance etc . I timed the engine on TDC with the magneto mark aligned as per the manual but I find the cam timing slightly odd. The arrows pointing upward are on the 1st and 15th pin as they should but with the magneto timing mark aligned they are not perfectly straight. Same goes for the arrows that should be parallel to the cylinder head casing. Is this normal or should they be absolutely perfect ?
       

×