Cutting out sputtering at full throttle

My bike will cut out every time when I'm at full throttle and start to over rev. When it reaches max rpm's it cuts out continuously for about half a second at a time. I've tried both a richer main jet and leaner and it didn't seem to make a difference. The spark plug looks fine (light brown) and I run ethanol free 93, 40:1. I've tried straight AVgas 40:1 and it didn't make a difference.

I don't think its jetting, fuel or carburetor related. It seems to cut out more frequently when I ride it hard and it gets really hot. It runs perfect up until it reaches max rpms and then it starts sputtering. Does anyone have any ideas?

Bad coil/bad spark plug/bad stator. One of the three.

Thanks Will, I bet its one of those 3.  Someone said that cutting the sparkplug wire and re-installing the cap might fix it.

If u have a manual it should tell u the ohms the coil should read . That might help u find out if its a bad coil butt since its not acting up all the time it could read good and be bad . Redoin cap connections a good idea .

What bike is it?  What has been done to the engine and what jets are in it now?

 

Does the type of load on the engine seem to make a difference?

 

Have you completed a w/o throttle plug chop test?

 

Has it ever run properly with the current configuration of engine, carb., and electrical system?

Edited by kx450f63

What bike is it?  What has been done to the engine and what jets are in it now?

 

Does the type of load on the engine seem to make a difference?

 

Have you completed a w/o throttle plug chop test?

 

Has it ever run properly with the current configuration of engine, carb., and electrical system?

 

2011 150sx.  Engine is stock, new vertex piston but it was doing it before too. 

Yes the load does make a difference.  If the engine is pulling hard up a hill and its not completely revved out then it won't sputter.

I haven't done a full throttle plug chop with a new plug but I have changed the plug and changed the main jet from 182 - 188 it doesn't make a difference, it still cuts out.  My jetting isn't the problem. 

Ever since I first got it this summer I've noticed the cutting out.  Sometimes it will cut out less so I just ignored it because instead of revving it completely out I would switch gears then it would be fine.

Cutting the spark plug coil and replacing the cap didn't fix it.  Looks like I'll take a look at the cdi next, maybe replace it.

maybe check the air filter, might not be getting enough air into the mix when at full throttle cause of how much it will need

Not sure if it's the same solution but it sounds like the same problem I had after over adjusting the float bowl. I could fly up to 5th gear on the power only to cut out intermittently before hitting the normal peak. 

2011 150sx.  Engine is stock, new vertex piston but it was doing it before too. 

Yes the load does make a difference.  If the engine is pulling hard up a hill and its not completely revved out then it won't sputter.

I haven't done a full throttle plug chop with a new plug but I have changed the plug and changed the main jet from 182 - 188 it doesn't make a difference, it still cuts out.  My jetting isn't the problem. 

Ever since I first got it this summer I've noticed the cutting out.  Sometimes it will cut out less so I just ignored it because instead of revving it completely out I would switch gears then it would be fine.

 

 

Sounds rich on the main jet. Sputtering, but improves with load, classic symptoms.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now