Jump to content
Sign in to follow this  

KX250f Starting issue

Recommended Posts

Please help anyone.

Quick background on the bike. Got the bike about a month ago previous owner floated a valve he replaced the piston and had the head work done by a shop all new Kimble springs and valves. He put it all back together and could not get it to start so left it. I purchased it and took it home took the top end apart and replaced a spun ex cam re shimmed all the valves. Bike ran perfect until the other day I started it and took it up the road where it sputtered and felt like it ran out of gas when I looked I was almost out so I pushed it back home and didn't try to start it.

 

Took it to the track yesterday and filled it with fuel and kicked the living hell outta it and nothing took it home and pulled the plug to find it was black and soaked so I replaced that and got a little sputter with the new plug but that was it.

     

Things I have done tonight

Checked timing its good

Checked intake valve clearance its good .005 fits .006 wont

cleaned carb fuel screw is 2 1/2 out and have a 42 pilot in there. 

 

Any ideas?

 

Share this post


Link to post
Share on other sites

Did you test for spark? My 450 did the same thing... contacts where the stator connects to the cdi were corroded. Found this after a new stator did the same thing after 2 tanks of gas.

Share this post


Link to post
Share on other sites

yes I did check spark and I am getting it that's why I was ruling out the CDI. Weird thing is as I kick it oil drips out of the crank case vent it did have a little over oil and I have since drained it.

Share this post


Link to post
Share on other sites

Weird thing is when the plug is out it still feels like it has compression, shouldn't it be easy to kick with the plug out? 

Share this post


Link to post
Share on other sites

Weird thing is when the plug is out it still feels like it has compression, shouldn't it be easy to kick with the plug out?

that is normal the compression you can feel is the springs on your valves

Share this post


Link to post
Share on other sites

Fixed!!!!!! I bump started the bike and it came to life and also starts with the kick starter. The only thing I can think of is I put a thumb fuel screw on last week and something happened there because I am now back to the screw and the bike is kicking and starting. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×