Jump to content
Sign in to follow this  

13 250f questions

Recommended Posts

Hey guys new to the forum and new to kawisakis. I bought my 13 kx250 a few months back and have out about 15 hours on the bike. And my fork seals are leaking already. Has anyone else had this issue. Also the service manual says to change the piston and rings. Every 6 races or 15 hours. Is this necessary? I only use the bike for trail riding. And every 15 hours seem a bit excessive for a 4 stroke. Any input will be helpful thanks

Share this post


Link to post
Share on other sites

You trail ride, as do I. I've read that exact chart in the manual and giggled a little. Changing the piston that often is absolutely excessive, and it is somewhat normal (for your bike anyway) that fork seals started leaking. I've had both like-new 2009 and 2011 models and it's the same story. They're apparently notorious for frequent-leaking seals. Back to the engine, if you don't think you absolutely abuse your bike then your engine is completely fine. Racers definitely change top ends much more often. Now about when to change the top end, that could be a multitude of things. I know for a fact there's numerous beliefs based on when to change main engine components but it really relies on how you've used and maintained your bike. But as you are a trail rider like myself I would say at about 80-100hrs, given relatively light use. I hope this helps

Edited by JC116_MTL

Share this post


Link to post
Share on other sites

I have a 12 that also started leaking fast. I bought the SKF seals and they are holding nice for the past 35 hours. For the piston just check the compression, that's the best way to know.

Share this post


Link to post
Share on other sites

My 13's seals are leaking too. But it looks like the seal is pulling out of the fork. And leaking there, not right where the stanchions come through the seal

Share this post


Link to post
Share on other sites

My fork seals done the same thing about 15 hrs and I have just put a new piston in mine after about just under 30 hrs. The piston I took out had a little wear but could have lasted a bit longer. I only changed it because I heard a few horror storys. I ride MX only and I am a fast intermediate  or slow expert. I will change the next one at 40 hrs hope this helps.

Share this post


Link to post
Share on other sites

i use seal mates every few times i clean my bike on my 09 which ironically is jc116_mtl's old 09.  Dirt and grim gets up between the seal and fork tube which is what causes the leak normally.  Takes under 5 min per leg and really does work great to get all the gunk out, I use them on all my bikes and it has prevented me from having to change seals on all of them, I thought the seals were shot but it was just dirt up there, once i cleaned em they were as good as new!

Share this post


Link to post
Share on other sites

I've got roughly 50 or 60 hours on my piston riding hare scrambles and messing around. I'll change it over the winter (providing I don't have some failure earlier). my fork seals were leaking after 3 hours of trail riding, then I found out the dealer I bought it from had bound the forks up by putting the front tire into the forks and tightening in the wrong sequence. you have to make sure you get both sides of pinch bolts loosened after you get the axle snug, pump the front end a few times and then tighten them all up. when it's done correctly you'll see about a 1/8" gap on the rh spacer between the lower tube and the spacer. this was binding the front end as well. I also bought a set of shok sox and they've worked really well at keeping crud out of the seals. 20 bucks and worth every penny in my opinion. I've got the bluish / green seals in my tubes from works enduro rider, idk who makes them but I've had zero issues since they were put in there.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

  • Similar Content

    • By Toms.abpg
      Just bought this bike and the pop on decel is horrible, looks like I’m gunna have to try a Tokyo mods remap. Anyone had success with this ?
    • By _Cloudy_
      Hi, I have just bought a kx250f, 2013 with a freshly rebuilt 2016 motor in it, this is my first time on these forums, anyways, I have also bought a lowering link to drop it 4 inches on the arse, I was wondering if anyone knows how much I should drop the forks? 
      I havent put the lowering link on yet. 
      Thanks.  
    • By Zach Miner
      Recently had issues with the original fcr carburator that was installed in my 2009 kx250f, tried jetting multiple time and different gas and the bike would only run with the choke ziptied out. Do I went ahead and purchased the lectron gen 2 4 stroke carburator kit, was kinda expensive and I was kind sceptical but after my first ride all I got to say is wow. The only adjustment I have done it set the idle, the bike runs amazing and feels as if there is more power than before. The kit came with a new throttle tube assembly and a g2 throttle tube with adjustable cams for throttle response. I highly recommend if you have a carburator on your four stroke and don't want to get a new dirtbike that is fuel injection then go the route of throwing out that junk fcr carburator and get a lectron gen 2 carburator for your old 4 stroke

    • By DirtbikeDon
      I own a 2012 Kx250F that I would like to make street legal if possible and I recently saw Rocky mountain I believe sells these battery packs that sit in the airbox for bikes without batteries that looks too good to be true and a headlight and turn signals like a conversion kit basically and I was curious as if anyone has had luck with those or if there junk it would be nice to make my bike street legal for short trips or just have lights for trail riding with friends that already do if possible any tips on converting it? 
    • By kylesmith_14
      The launch control only lights up when you first start up the bike when you try to use the launch control it doesnt light up at all ive tried 1st 2nd and neutral for 3+ seconds ive cleaned the connections and also cleaned the neutral saftey switch or gear selector and still no luck any help would be appreciated
×