Jump to content
Sign in to follow this  

Im new here. Got ttr 125 questions

Recommended Posts

I have just acquired a pretty rough specimen of a ttr 125.Its for my 15 yr old daughter and its her first motorcycle. According to the vin its a 2004 lw model. Now the questions,it starts up fairly quick when cold with 2 or 3 kicks,it runs for about 5 minutes then will rev down and stop. The revs do seem quite high but I have no way of knowing how high. I rode it tonght for about 15 munutes with 3 seperate stopping episodes where it took 3 minutes or so to start again. After start up it ran pretty well and hauled my 250 lbs self around admiarably. Some facts I notice,the choke seems to do nothing to the revs,in or out its the same thing. The plunger {whatever its called] seems to pop out of the cylinder . I push it back in with my fingers and reattach the rubber boot over the outside of cylinder. None of this makes any noticeable difference,it runs the same at a seemingly high idle . I known nothing about how this bike was taken care of,i got it and a parts bike for 450 bucks. Hoping you fellas or ladys can help me and point me in the proper direction. Thanks

Mike

Share this post


Link to post
Share on other sites

stock pilot is to lean.  run a 17.5.  clean out the main.  if you open the airbox and get a pipe, you will need a larger main also.  then adjust the fuel screw.

Share this post


Link to post
Share on other sites
Some facts I notice,the choke seems to do nothing to the revs,in or out its the same thing. The plunger {whatever its called] seems to pop out of the cylinder . I push it back in with my fingers and reattach the rubber boot over the outside of cylinder. None of this makes any noticeable difference,it runs the same at a seemingly high idle .

 

Not sure I understand what you're talking about here.  Are you saying the plunger that the choke cable is on pulls way up and out of the carb when you pull it?  Far enough to cause the rubber boot to detach from the carb? 

 

If that's the case, then the choke cable has probably come loose from the 'plunger' inside the carb.  You're likely moving the cable end up and down inside the carb but not the plunger itself.  That's why pulling the choke doesn't do anything. 

 

It's possible the detached choke plunger is stuck pulled in the 'up' position inside the carb.  If that's the case the choke would be on all the time and it would cause high idle at cold start like you described, but when it warmed up it would run terribly because the choke was still on. 

 

I'd take the carb off (it's easy) and then loosen that big nut that holds the choke cable to the carb and check out what's going on inside there.  Probably wouldn't hurt to take the entire carb apart and clean it real good too. 

 

Post some pics of the rubber boot and plunger you're referring to if you can. 

Share this post


Link to post
Share on other sites

Ddact,I think your right and you do understand what I meant. I'm gonna pull the carb this weekend and take a look. Last night I also found the petcock to be defective so will be replacing that as well. This littler ttr needs a lot of work,hopefully most of it will be cheap. Thanks for the help!

Share this post


Link to post
Share on other sites

Ok,I got the carb off the bike and I cant get the "plunger" to budge inside the pocket. I have soaked it for several days using liquid wrench and still its stuck. Any pointers on how to get this bugger apart?

Share this post


Link to post
Share on other sites

try using coke.... the liquid refreshment.

worked for others. Try a search, ttr125 choke plunger for more.

Share this post


Link to post
Share on other sites

I searched it after I made that last post. It sure seems like a common problem!

Share this post


Link to post
Share on other sites

The issue was resolved. After taking a closer look I saw I was able to get a screwdriver blade in the slot of the plunger and just break it loose. Its out and all is well.

Share this post


Link to post
Share on other sites

No,not even reassembled yet. I'm waiting for bikebandit to ship. I ordered a new petcock,fuel lines from them and carb rebuild kit ,front brake assembly from ebay.my kids getting very antsy waiting to learn to ride her first dirtbike!

Share this post


Link to post
Share on other sites

Okeedokee. its running now. I took the whole carb apart and used our shops ultrasonic cleaner to clean the carb and all metal parts. I then used all new o rings and did some manual cleanup of the choke cavity. It runs pretty well now and just needs some minor tuning to bring her into form. Thanks for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×