Jump to content
Sign in to follow this  

2008 CRF 150R clutch grabbing

Recommended Posts

Hello, I hope I am posting this in the correct location.  I recently purchased a used 2008 CRF 150R a couple weeks ago.  I went through and gave it all a good once over, changed fluids, rebuilt the forks, adjusted the valves, etc etc.  While I was in there I also wanted to go ahead and replace the clutch.  I purchased a barnett clutch kit with new steels, friction plates, and springs.  I put it all back together and filled it with Honda trans fluid 80/85.  I took it out and the clutch seems to not slip at all.  It almost goes from completely disengaged to engaged over the course of 1/16th inch.  My cable and lever free play is adjusted correctlly and it is still doing it.  I thought maybe my problem may have been due to using the Honda trans oil instead of regular Honda 10w40 engine oil.  I swapped for the regular oil and it is still doing the same thing.  It is important to note that it did not have this problem before I replaced the clutch components.  Any ideas what it could be?  The oil doesn't seem to be the issue.  I was thinking maybe I need heavier springs, but I have no idea.  This isn't the first time I have repalced a clutch and I am not new to bikes, but I can't seem to figure this one out.

 

Thanks for any help you can provide.

 

Brian

Share this post


Link to post
Share on other sites

Never mind, figured it out, the clutch basket was severly grooved, causing the plates to not be able to slide in the basket.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×