Bike won't shut off after crash very strange

Hey guys, I am a new rider here (as in on this forum) and I really need some assistance.

So basically I looped out on my TE511, then it ran for a few miles then it shut off and the main 30amp fuse was blown. I replaced it and found a bad short in the tail light then it wouldn't start. The dash would light up, but but nothing would fire or try to start. When I let go of the starter button the dash would immidiately shut off. Then this afternoon I just say what the hell and try it. It starts up, but keeps firing when I press the shut off button or if it stalls. The only thing I can do is unplug the battery. I checked the starter and shut off buttons which were fine. I looked for a short and couln't find one anywhere, but I also don't know specifically were I should be looking. After reading other posts about people who couldn't shut off the bike it seems like it could be the solenoid, but that seems to only be an issue for older bikes(this is a 2012). I fell hard by my standards but it wasn't catastrophic. The bike still ran for a while afterwards.

 

Any words of wisdom are welcome.

Thanks

The on/off switch might have took a hit. Try taking it apart and see if you have something going on inside there.

The on/off switch might have took a hit. Try taking it apart and see if you have something going on inside there.

I already shecked them, they were fine. I even hotwired the bike with a jumper and still the same issue.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now