engine backfire after throttle let off?

Polaris

I just picked up a 2010 Polaris Outlaw 525 from my cousin. It's been sitting for about a year. The thing started right up ran good at idle. riding around the yard It seemed to be ok.Ran it a bit more. Got on it and after letting off the throttle it's backfiring and seemed to bog a bit at slow speed, I changed the plug ( looks like it's running rich). Drained all the gas, including the carb. Sprayed carb cleaner in it. Changed the oil. I'm stumped. Any input would be appreciated.

I just picked up a 2010 Polaris Outlaw 525 from my cousin. It's been sitting for about a year. The thing started right up ran good at idle. riding around the yard It seemed to be ok.Ran it a bit more. Got on it and after letting off the throttle it's backfiring and seemed to bog a bit at slow speed, I changed the plug ( looks like it's running rich). Drained all the gas, including the carb. Sprayed carb cleaner in it. Changed the oil. I'm stumped. Any input would be appreciated.

sounds like it's running lean . Rchen it up a little. Get 3 she's bigger and 3 sizes smaller pilot jets and adjust till you find the right setting .

I just picked up a 2010 Polaris Outlaw 525 from my cousin. It's been sitting for about a year. The thing started right up ran good at idle. riding around the yard It seemed to be ok.Ran it a bit more. Got on it and after letting off the throttle it's backfiring and seemed to bog a bit at slow speed, I changed the plug ( looks like it's running rich). Drained all the gas, including the carb. Sprayed carb cleaner in it. Changed the oil. I'm stumped. Any input would be appreciated.

Pilot jet is clogged from it sitting. Five buck for a replacement from the dealer my friend.

Pilot jet is clogged from it sitting. Five buck for a replacement from the dealer my friend.

Thanks dude, thats what i figurd it was. The sparkplug was pretty black when I pulled it. Changed it out, it looks good coco brown color. I'll change the jet and see how it works. I was impressed how fast the thing is. It moves.

Thanks dude, thats what i figurd it was. The sparkplug was pretty black when I pulled it. Changed it out, it looks good coco brown color. I'll change the jet and see how it works. I was impressed how fast the thing is. It moves.

if it sounds like this http://www.youtube.com/watch?v=yb7wEYvHf4w its a clogged pilot 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now