Jump to content
Sign in to follow this  

Clutch Cable at case

Recommended Posts

Anyone have an issue with the black seal popping out where it meets the case (under the little bootie)? Have had it happen a few times and noticed some oil covering the stator cover. I just pushed it back down, checked the oil through the sight glass and kept going.

Share this post


Link to post
Share on other sites

Mine is always popped off at the case, it bugs me but I don't think it is truly causing any internal damage. Would live to find a good solution.

If you find or hear of a way let me know. It's a PITA... Edited by GreenHornet450

Share this post


Link to post
Share on other sites

put on the zip ties at both ends, we'll see how it holds up on the ride tomorrow. thanks for remind me that i needed to do something about the cable boot.

  • Like 1

Share this post


Link to post
Share on other sites

put on the zip ties at both ends, we'll see how it holds up on the ride tomorrow. thanks for remind me that i needed to do something about the cable boot.

It's just not the boot, but the circular seal that seals the cable going into the case.

Share this post


Link to post
Share on other sites

zip ties held at both ends, why was I so lazy to not do this earlier....

I'm going to try that today for Tomorrow's ride.

Share this post


Link to post
Share on other sites

He's talking about the lip seal popping out, not the rubber boot/dust cover.

 

I would imagine a tiny drop of Super Glue would hold it in place, around the outside of the seal. Carefully clean it first to remove the oil.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×