My cams wont spin! Is HEAD WARPED

 i took decent used cams and put them in a used head i bought. when i put the cam clamps on they are hard to spin, and with bolts tightened they wont spin freely at all, like the bearings are seized.  They spin fine on old head, while clamped down with bolts fastened!!!! Could the used-head i bought somehow be warped? How would i be able to know for sure? 

Could be. Did you put any oil or moly lube on or was it bone dry?

i took decent used cams and put them in a used head i bought. when i put the cam clamps on they are hard to spin, and with bolts tightened they wont spin freely at all, like the bearings are seized.  They spin fine on old head, while clamped down with bolts fastened!!!! Could the used-head i bought somehow be warped? How would i be able to know for sure?

Did you lube the cam and bearing caps and use an inch pound torque wrench?

i'd bet that the cam caps have been over torqued before and are not round any more.

 

and as 418 pointed out, did you use the proper inch pound torque wrench in 3 steps?

I have responded to similar cam problem posts in the past. Often times, the cam is just not "happy" with its alignment position within the bore. Do a search of my past posts and you'll see the explanation of how to correct the situation.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now