Yz250 clutch stuff

so as many of you have probably realized, i had a huge thread regarding my yz250 about a month ago. Well, all is good! Just had a little question... When i have the clutch pulled in, and i give it a pretty high rev, i can feel it BARELY move forward (or at least try to). It doesn't stall, and it doesn't lurch at all. Just barely tries to move forward. Enough to grind my gears... pun not intended. Does this happen to anyone else? is it just the vibration of the bike? Doesn't try to do this unless it's a high rev.

It's normal. Go ride your bike.

And apologize to me :)

It's normal. Go ride your bike.

And apologize to me

 

FINE IM SORRY:p

FINE IM SORRY:p

Hahaha but yeah you are fine. I think it's the same principle as your wheel spinning while the bike is running in neutral on a stand. Just everything is spinning so you're bound to get movement of some kind

Hahaha but yeah you are fine. I think it's the same principle as your wheel spinning while the bike is running in neutral on a stand. Just everything is spinning so you're bound to get movement of some kind

this is true!

Hahaha but yeah you are fine. I think it's the same principle as your wheel spinning while the bike is running in neutral on a stand. Just everything is spinning so you're bound to get movement of some kind

It also does a pretty violent shift into second from neutral... is that also normal? The only reason i ask is because i was having trouble getting neutral, but i realized that it takes a lot less force to get into neutral with boots on.. duh. So i tried to go into second and it just felt like a violent click. Normal?

Yeah sometimes when my bike is cold and I go to put it first it will click really loud

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now