2009 RM-Z450 off idle bog

Hi guys,

 

I recently purchased a 2009 Suzuki RM-Z 450. The bike has a terrbile bog when it's on the stand and you crack the throttle. It either bogs or just dies completely. If you ease into it, it runs fine. It idles fine and starts without issue. Just a crack of the throttle will kill it almost every time. I have not had a chance to ride it yet at the track because of this issue. Any advice on what it could be? Bike is totally stock.

 

I've done a few searches and some suggestions for other FI bikes are clogged fuel injector, fuel pump, coolant temp sensor or wiring harness. Just trying to narrow it down.

 

Thanks.

Edited by reean917

Pull the tank, pull the pump, clean or replace the fuel filter attached to the pump.

Pull the injector, power it with a 9v battery to cycle it open/closed, and soak the tip in solvent for 15 min in each position, then spray cleaner to remove the debris.

Do not get any solvent on the rubber parts.

Check all rubber lines for contamination and disintegration. Lots of FI bikes have been shipped out of japan with rubber hose that is defective, and rots from the inside.

If all that doesn't solve your problem, you probably have a worn out or damaged fuel pump. You can test it with a pressure meter. You want 50+ ft/lbs minimum.

Thank you! That's exactly what I was looking for. I'll try this weekend and report back.

How your bike is on the stand means nothing. Do not adjust anything until you have ridden it.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now