Oil filter installation

I recently bought a 2010 yz450 and I just performed my first oil change on the bike. This is my only concern: does the oil filter just go over the post on the engine side and seal magnetically? Nothing has to line up or anything right? I'm coming from an 09 kx450 and it was quite different. I just don't want to cause any issues with this bike by messing up something so simple. Thanks and sorry for asking such a stupid question.

Just put it in how it came out and you'll be good.

I appreciate the reply but that doesn't really answer my question. I know the filter can only go in one way (the side with the hole towards the motor) but I want to make sure that is the only detail I need to pay attention to.

I appreciate the reply but that doesn't really answer my question. I know the filter can only go in one way (the side with the hole towards the motor) but I want to make sure that is the only detail I need to pay attention to.

As an actual owner and rider of a Yamaha, yes you are correct in your installation.  It centers itself with the cover, really the only thing I've ever had a problem with is the lower cover bolt/drain.  It can bind on removal after a "too long" time period between changes.  I think particles get in there and bind it up, just go slow with that bolt in the future, if it starts to bind back it in and work it out slowly.  You do have a manual right ?

The lower bolt on the '10 and later models isn't used as an internal drain  anymore as the older ones were, so that's no longer a worry.  The filter seals only on the end with the hole in it.  The "seal" on the other end (cover side on the later models) is just a pressure pad to hold the filter snugly against the seal. 

Thank you, timpjr and yes, I do have a manual.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Zack Ailing
      hey guys just picked up a new project bike. Its a 2008 Yz450f with a big bore kit and a stroker crank. The total cc of the engine is now 499. It runs on race gas and will be an absolute monster when shes ready to rip. I will continue to make more videos on the bike so stay tuned Link to the video: 
    • By High On Octane
      2005 YZ450F, Athena Big Bore, Power Bomb, Q4.
      Ok.  Last fall after a decently hot day at the track, I noticed coolant leaking from the weep hole on my water pump after pulling into the pits.  Ordered an Athena re-seal kit, put it all back together and didn't really get a chance to ride it.  3 weeks ago, went out to the track, and after about 20 laps, it started leaking again.  Kept filling it with water to get thru the day, never ran anywhere close to dry or empty, jut a cup or 2 low.  Ordered a Hot Rods re-seal kit with bearing and also ordered a new w/p shaft.  Did it all again and got it back together, ran it, and as soon as it got to temp, it was leaking out of the weep hole again.
      So, what the heck am I missing?  I'm totally stumped on this one.  Is something wrong with my case cover?  Do I need to replace the w/p itself?  I'm feeling like I should've just ponied up for the Boysen in the first place, and now it's biting me in the butt.  Any help or suggestions is greatly appreciated.  Thanks!
    • By Awheeler25u
      Alright guys, my 04 YZ450f runs fine minus some slight backfires when decelerating (need to adjust fuel screw). The other day when I was done checking my valve clearances I changed the oil and filter and put the bike back on the stand, kicked it a few times without the ignition coil in to get some oil flowing got off and noticed a little drip spot on the ground, it was no bigger than a dime so I thought nothing of it. Started the bike with no issues took it for a quick 10-15 min ride, came back to the garage to find out my whole case was soaked with oil and it started pooling in the low spots on the clutch basket side. I cleaned all the oil off and took it out again for 5 mins to try and see where it was coming from, here are my three possible places but nothing directly leads me to believe it’s any of the three either.
      1. Decompression plug area
      2.  Valve cover gasket leak (not really sure because the amount of oil leaking Looks to be a large amount
      3. Oil tank (bad weld or cracked weld somewhere
      what are you guys thinking?
    • By bofar
      Hey guys. I could really use your help diagnosing an issue that came up riding today. Bike is a 2013 YZ450F. Well maintained and haven't had any issues until now. Both the oil and coolant are new and levels are to spec. 
      After riding for about an hour in the sand dunes, I noticed a grinding going on on the right side of the bottom end (from what I could tell). When I looked to see what was going on my kickstarter was vibrating and grinding really loud. This was a different sound than if you engaged the kickstarter while running. It sounded less "clanky" and more "vibrating/grinding" if that makes sense. Grabbing the kickstarter and moving it didn't help the issue.
      When I noticed it, I shut the bike off and gave it a second. Being a few miles deep into the dunes, I had to get it out of there so I started it back up and it seemed fine- no grinding. I headed back to the car and after a few minutes, it came back so I shut it off again, started it back up and nothing. That process happened one or two more times before I made it back to the truck. Seemed to run fine otherwise. 
      Once I got it back to the truck I started it up and tried to pay more attention to what was going on but it wasn't doing it. I did seem to have more of a metal on metal noise coming from the motor. I started and stopped the bike a few times and after the motor stopped there was a distinct metal clank/grinding noise that happened right after the motor shut of for maybe half a second. This doesn't happen every time. 
      I tried doing some research and have seen things that make me think it could be the spring that connects to the kickstarter, or the kickstarter stopper plate- but really I have no idea.
      Seems strange that the issue is off and on.
      Thanks for the help!
    • By Goof331
      Does anyone know if there is any differences between the 2 radiators? Will the yz450fx radiator bolt on a yz450f? What I am wanting to do is wire up a fan to my 2016 yz450f. I know how I am going to do it I just don’t want to use a “universal” fan kit. What I would like to do is get a 450fx radiator and the direct bolt on Trail Tech fan for that radiator to have a good clean look.