Jump to content

KLX250s is bogging down when you hit the throttle.


Recommended Posts

This is my first post on this site so im not sure im doing this right but... I have a 2012 klx 250s and its mods that make a difference to my problem are Fmf powerbomb header, dgr slip on, dynojet kit 2, and the smog thing and the snorkel ( not the lid just the snorkel ) have been removed, and the crankcase vent has been opened up. I recently just did all these mods and tightened the cam chain ( it was slapping around inside) and it ran beautifully for a few rides. I road it hard and long through trails all day yesterday and it did fine. I hit the one last trail on the way home and got stuck in some brackish water id say it was def more fresh water than salt tho. I was riding thru sand all day too. So while i was stuck it kept dying, prolly getting water in the air box, and it got so stuck that i drained the battery from trying to start it so much. I finally pull the bike out and try to pop the clutch and fail then i hook it up to this dudes truck battery to jump my bike. It would not start til i laid the bike over to the left and kept feathering the throttle. It ran bad for awhile but i just let it run for like 20 mins while i changed clothes and got my gear. Then it was time to go and it road and pulled hard for the entire highway 20 mile ride home. Today i change the oil and put 2 oz's of pj1 carb cleaner in the gas tank. I ride it to work and it only barely ran odd for a second so i didnt think it was anything. Get to work the bike sits for like 4 hours and then i hop on for my lunch break and i hit up this basic no water no nothing of a trail and it pulls hard as normal then get back on the road and it runs like crap all of a sudden, and it bogs down the second you try to give it like 15% of throttle and since my battery had died the other day i didnt know how much gas it had in it so i figured it was just time to switch it over to the RESERVE tank.You know how the bike gets when its running out of gas and you just click it over to the RESERVE thats how it felt almost.Nope that def wasnt the problem, it ran like garbage all the way back to my work and i even had to ride with the choke on and barely giving it any gas at all just to try to get it going any faster at all, i mean it was really turtling up to granny speed. I get back to work and think theres water in the motor, in the past i was told if you get water in the airbox then it goes in the motor DUH if you pull the spark plug and lay the bike down on the left and hit the starter it will spray any water out. In the past even from day one this trick has saved my ass many times. So i do this and it doesnt make it any better so i ride home at turtle granny speed style with the choke on. I get home, research the possibilities , everyone is saying the carb vent is blocked with mud or the the carb needs to be cleaned out. I check the vent and hose, there was some scattered grains of sand in the hose, i clean the hose and the vent. Then i pull the carb off and clean that with carb cleaner. Put the diafram in wrong the first time cuz the needle wasnt smooth and do it again and the needle was sucking back out perfect just like when i put in the jet kit. Put the carb back on and take it for a spin, it pulls pretty good almost perfect right off the bat but then once again after a 1/2 mile i pin the throttle back trying to feel the torque pick the front end up and it bogs the motor down hard like it did before. I AM OUT OF IDEA'S, AND I AM IN DESPERATE NEED OF ADVICE. please help me. Sorry its so long.

100_0049.JPG

100_0022.JPG

Link to comment
Share on other sites

If you got your bike deep enough to get water in the air box then it got into a lot of other things too. Blow compressed air into anything that has an opening and unplug electric connectors to make sure they do not have moisture in them. Check all the clear plastic tubes that come off the carburetor to make sure there is not a blockage. Open your carburetor drain periodically to clear it as any water in the fuel will migrate to the lowest point. You get the idea. It just seems that water has gotten somewhere you do not want it and until it is removed you will continue to have problems.     

Link to comment
Share on other sites

I have a 2009 KLX 250s. I bought it used with 2500 miles. It erratically revs past about 6000rpm to 7000rpm. It has no modifications except I noticed the top of the air cleaner box was missing as well as the plastic screen that pushes the foam filter against the round plastic inlet. It starts immediately but I have to let it warm for several minutes before I can ride because it will bog down when I try to rev it. I choke it to start but can immediately turn off the choke and it will idle.

Link to comment
Share on other sites

  • 5 months later...
  • 1 month later...
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...